aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:53:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:53:37 +0000
commit95e9090b24c911d8a87ec615e4b7871456543991 (patch)
treebc24c9601c5a34eb1097d4a00c115548405e660c
parent2c65a103286e76e39b6519fe4a2a4b0e25e90909 (diff)
downloadalpine_aports-95e9090b24c911d8a87ec615e4b7871456543991.tar.bz2
alpine_aports-95e9090b24c911d8a87ec615e4b7871456543991.tar.xz
alpine_aports-95e9090b24c911d8a87ec615e4b7871456543991.zip
extra/dovecot: upgrade to 1.1.13
-rw-r--r--extra/dovecot/APKBUILD19
-rw-r--r--extra/dovecot/dovecot-1.1.11-4736327a8740.patch20
-rw-r--r--extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch49
-rw-r--r--extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch26
4 files changed, 4 insertions, 110 deletions
diff --git a/extra/dovecot/APKBUILD b/extra/dovecot/APKBUILD
index 17d9faec34..8b6ba6a7e3 100644
--- a/extra/dovecot/APKBUILD
+++ b/extra/dovecot/APKBUILD
@@ -1,31 +1,23 @@
1# Contributor: Michael Mason <ms13sp@gmail.com> 1# Contributor: Michael Mason <ms13sp@gmail.com>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=dovecot 3pkgname=dovecot
4pkgver=1.1.11 4pkgver=1.1.13
5pkgrel=1 5pkgrel=0
6pkgdesc="IMAP and POP3 server" 6pkgdesc="IMAP and POP3 server"
7url="http://www.dovecot.org/" 7url="http://www.dovecot.org/"
8license="LGPL-2.1" 8license="LGPL-2.1"
9depends="uclibc libcap zlib openssl" 9depends="uclibc libcap zlib openssl"
10makedepends="libcap-dev zlib-dev openssl-dev" 10makedepends="libcap-dev zlib-dev openssl-dev bzip2-dev"
11install="dovecot.pre-install" 11install="dovecot.pre-install"
12subpackages="$pkgname-doc $pkgname-dev" 12subpackages="$pkgname-doc $pkgname-dev"
13source="http://www.dovecot.org/releases/1.1/$pkgname-$pkgver.tar.gz 13source="http://www.dovecot.org/releases/1.1/$pkgname-$pkgver.tar.gz
14 dovecot.initd 14 dovecot.initd
15 dovecot-1.1.11-4736327a8740.patch
16 dovecot-1.1.11-bdc5391e52df.patch
17 dovecot-1.1.11-c08c602ca0dc.patch
18 $install 15 $install
19 " 16 "
20 17
21build() { 18build() {
22 cd "$srcdir/$pkgname-$pkgver" 19 cd "$srcdir/$pkgname-$pkgver"
23 20
24 for i in ../*.patch; do
25 msg "Applying $i.."
26 patch -p1 < $i || return 1
27 done
28
29 ./configure --prefix=/usr \ 21 ./configure --prefix=/usr \
30 --sysconfdir=/etc \ 22 --sysconfdir=/etc \
31 --mandir=/usr/share/man \ 23 --mandir=/usr/share/man \
@@ -40,9 +32,6 @@ build() {
40 install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname 32 install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
41} 33}
42 34
43md5sums="c973eb41aca79fb16630a16f0d84f765 dovecot-1.1.11.tar.gz 35md5sums="8f3e10d0161429b15546a8ad6e8b4d25 dovecot-1.1.13.tar.gz
44573e14589a6f8424d55753a2794ab99a dovecot.initd 36573e14589a6f8424d55753a2794ab99a dovecot.initd
457e1cd399255fbacff197c0ba79b0c2c2 dovecot-1.1.11-4736327a8740.patch
46f95cc06111ba3b83399a28cb1459fca0 dovecot-1.1.11-bdc5391e52df.patch
47d15abfa0c41426b99423d140d35b2fbd dovecot-1.1.11-c08c602ca0dc.patch
48f0f8893411f5e482e14f40a81a177b19 dovecot.pre-install" 37f0f8893411f5e482e14f40a81a177b19 dovecot.pre-install"
diff --git a/extra/dovecot/dovecot-1.1.11-4736327a8740.patch b/extra/dovecot/dovecot-1.1.11-4736327a8740.patch
deleted file mode 100644
index 7f0418e682..0000000000
--- a/extra/dovecot/dovecot-1.1.11-4736327a8740.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1
2# HG changeset patch
3# User Timo Sirainen <tss@iki.fi>
4# Date 1233868321 18000
5# Node ID 4736327a8740579e7c89a8b386de9af0266b07fa
6# Parent 7d175e4ea57d21162abbf43a61c5305cfe1995b3
7Maildir: Fix to earlier >26 keywords handling change.
8
9--- a/src/lib-storage/index/maildir/maildir-sync-index.c Wed Feb 04 17:44:01 2009 -0500
10+++ b/src/lib-storage/index/maildir/maildir-sync-index.c Thu Feb 05 16:12:01 2009 -0500
11@@ -336,7 +336,7 @@ maildir_sync_mail_keywords(struct maildi
12 ones. we can get these lists easily by removing common elements
13 from old and new keywords. */
14 new_indexes = array_get_modifiable(&ctx->keywords, &new_count);
15- for (i = 0; i < old_count && j < new_count; ) {
16+ for (i = j = 0; i < old_count && j < new_count; ) {
17 diff = (int)old_indexes[i] - (int)new_indexes[j];
18 if (diff == 0) {
19 array_delete(&ctx->keywords, j, 1);
20
diff --git a/extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch b/extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch
deleted file mode 100644
index ac1dc25989..0000000000
--- a/extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1
2# HG changeset patch
3# User Timo Sirainen <tss@iki.fi>
4# Date 1234226629 18000
5# Node ID bdc5391e52dfe4590e9e291eba2603ed87caef57
6# Parent 4ddf36b9ee8182f10d8d69af6577b677cda282a0
7master: Don't crash if auth process dies too early.
8
9--- a/src/master/auth-process.c Thu Feb 05 18:29:06 2009 -0500
10+++ b/src/master/auth-process.c Mon Feb 09 19:43:49 2009 -0500
11@@ -353,7 +353,7 @@ static void auth_process_destroy(struct
12
13 if (!p->initialized && io_loop_is_running(ioloop) && !p->external) {
14 /* log the process exit and kill ourself */
15- child_processes_deinit();
16+ child_processes_flush();
17 log_deinit();
18 i_fatal("Auth process died too early - shutting down");
19 }
20--- a/src/master/child-process.c Thu Feb 05 18:29:06 2009 -0500
21+++ b/src/master/child-process.c Mon Feb 09 19:43:49 2009 -0500
22@@ -219,10 +219,15 @@ void child_processes_init(void)
23 lib_signals_set_handler(SIGCHLD, TRUE, sigchld_handler, NULL);
24 }
25
26-void child_processes_deinit(void)
27+void child_processes_flush(void)
28 {
29 /* make sure we log if child processes died unexpectedly */
30 sigchld_handler(SIGCHLD, NULL);
31+}
32+
33+void child_processes_deinit(void)
34+{
35+ child_processes_flush();
36 lib_signals_unset_handler(SIGCHLD, sigchld_handler, NULL);
37 hash_destroy(&processes);
38 }
39--- a/src/master/child-process.h Thu Feb 05 18:29:06 2009 -0500
40+++ b/src/master/child-process.h Mon Feb 09 19:43:49 2009 -0500
41@@ -40,6 +40,7 @@ void child_process_set_destroy_callback(
42 child_process_destroy_callback_t *cb);
43
44 void child_processes_init(void);
45+void child_processes_flush(void);
46 void child_processes_deinit(void);
47
48 #endif
49
diff --git a/extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch b/extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch
deleted file mode 100644
index 17ce270515..0000000000
--- a/extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1
2# HG changeset patch
3# User Timo Sirainen <tss@iki.fi>
4# Date 1234481874 18000
5# Node ID c08c602ca0dcbc137a4ca965b3722953cabfa4fc
6# Parent 4044df5a4d12fef4086d7e604444467eb105f348
7"Maildir filename has wrong W value" error was missing new/cur directory in the middle.
8
9--- a/src/lib-storage/index/maildir/maildir-mail.c Tue Feb 10 12:19:05 2009 -0500
10+++ b/src/lib-storage/index/maildir/maildir-mail.c Thu Feb 12 18:37:54 2009 -0500
11@@ -485,8 +485,12 @@ static void maildir_mail_set_cache_corru
12 _mail->uid, &flags);
13 if (maildir_filename_get_size(fname, MAILDIR_EXTRA_VIRTUAL_SIZE,
14 &size)) {
15- i_error("Maildir filename has wrong W value: %s/%s",
16- mbox->path, fname);
17+ const char *subdir =
18+ (flags & MAILDIR_UIDLIST_REC_FLAG_NEW_DIR) != 0 ?
19+ "new" : "cur";
20+ mail_storage_set_critical(_mail->box->storage,
21+ "Maildir filename has wrong W value: %s/%s/%s",
22+ mbox->path, subdir, fname);
23 } else if (maildir_uidlist_lookup_ext(mbox->uidlist, _mail->uid,
24 MAILDIR_UIDLIST_REC_EXT_VSIZE) != NULL) {
25 maildir_uidlist_set_ext(mbox->uidlist, _mail->uid,
26