aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-14 15:29:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-14 15:30:40 +0000
commitb7b354bab573fbc5522c483f964a5d0de8db8101 (patch)
treebcde70c18827b11ef29a9ceaca0f5cf7727ffdc7
parent5da50e031c421e03362cca15053cfd8535237380 (diff)
downloadalpine_aports-b7b354bab573fbc5522c483f964a5d0de8db8101.tar.bz2
alpine_aports-b7b354bab573fbc5522c483f964a5d0de8db8101.tar.xz
alpine_aports-b7b354bab573fbc5522c483f964a5d0de8db8101.zip
main/libseccomp: backport patch to fix aarch64 build
-rw-r--r--main/libseccomp/APKBUILD9
-rw-r--r--main/libseccomp/tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-syscalls.patch36
2 files changed, 42 insertions, 3 deletions
diff --git a/main/libseccomp/APKBUILD b/main/libseccomp/APKBUILD
index 3f5c5db0e7..ef89eb6541 100644
--- a/main/libseccomp/APKBUILD
+++ b/main/libseccomp/APKBUILD
@@ -3,7 +3,7 @@
3# Contributor: Dan Williams <dan@ma.ssive.co> 3# Contributor: Dan Williams <dan@ma.ssive.co>
4pkgname=libseccomp 4pkgname=libseccomp
5pkgver=2.4.2 5pkgver=2.4.2
6pkgrel=0 6pkgrel=1
7pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism" 7pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism"
8url="https://github.com/seccomp/libseccomp" 8url="https://github.com/seccomp/libseccomp"
9arch="all" 9arch="all"
@@ -13,7 +13,9 @@ makedepends="$depends_dev"
13checkdepends="bash" 13checkdepends="bash"
14subpackages="$pkgname-dev $pkgname-doc" 14subpackages="$pkgname-dev $pkgname-doc"
15source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz 15source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz
16 remove-redefinition-prctl.patch" 16 remove-redefinition-prctl.patch
17 tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-syscalls.patch
18 "
17 19
18# secfixes: 20# secfixes:
19# 2.4.0-r0: 21# 2.4.0-r0:
@@ -43,4 +45,5 @@ package() {
43} 45}
44 46
45sha512sums="375a3c7c658be6a08b9bb30963e10bb49e8e066119e0be6d3d97faac3db18b8e2c6938d8b5d3874b2f5331ec8295170112fbae83b5a3b5a5bebc0d6705bdfdbb libseccomp-2.4.2.tar.gz 47sha512sums="375a3c7c658be6a08b9bb30963e10bb49e8e066119e0be6d3d97faac3db18b8e2c6938d8b5d3874b2f5331ec8295170112fbae83b5a3b5a5bebc0d6705bdfdbb libseccomp-2.4.2.tar.gz
46f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch" 48f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch
49e9c6adbc424c310802851ec486df23aedd8121397a9742f3a5ed4754a5eee7ec1701a6f5e220bb37911b8c48626ba00d70943fad43e489d740d0295e6e9b0dff tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-syscalls.patch"
diff --git a/main/libseccomp/tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-syscalls.patch b/main/libseccomp/tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-syscalls.patch
new file mode 100644
index 0000000000..5f688a4a7d
--- /dev/null
+++ b/main/libseccomp/tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-syscalls.patch
@@ -0,0 +1,36 @@
1From 35803ceb43c453762a3ab5177c5f8d5dbb813478 Mon Sep 17 00:00:00 2001
2From: Paul Moore <paul@paul-moore.com>
3Date: Tue, 5 Nov 2019 15:11:11 -0500
4Subject: [PATCH] tests: rely on __SNR_xxx instead of __NR_xxx for syscalls
5
6We recently changed how libseccomp handles syscall numbers that are
7not defined natively, but we missed test #15.
8
9Signed-off-by: Paul Moore <paul@paul-moore.com>
10---
11 tests/15-basic-resolver.c | 6 +++---
12 1 file changed, 3 insertions(+), 3 deletions(-)
13
14diff --git a/tests/15-basic-resolver.c b/tests/15-basic-resolver.c
15index 6badef1..0c1eefe 100644
16--- a/tests/15-basic-resolver.c
17+++ b/tests/15-basic-resolver.c
18@@ -55,15 +55,15 @@ int main(int argc, char *argv[])
19 unsigned int arch;
20 char *name = NULL;
21
22- if (seccomp_syscall_resolve_name("open") != __NR_open)
23+ if (seccomp_syscall_resolve_name("open") != __SNR_open)
24 goto fail;
25- if (seccomp_syscall_resolve_name("read") != __NR_read)
26+ if (seccomp_syscall_resolve_name("read") != __SNR_read)
27 goto fail;
28 if (seccomp_syscall_resolve_name("INVALID") != __NR_SCMP_ERROR)
29 goto fail;
30
31 rc = seccomp_syscall_resolve_name_rewrite(SCMP_ARCH_NATIVE, "openat");
32- if (rc != __NR_openat)
33+ if (rc != __SNR_openat)
34 goto fail;
35
36 while ((arch = arch_list[iter++]) != -1) {