aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2020-10-10 15:07:07 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-10-10 13:46:39 -0300
commitbcf88ad2c00977427d4bb1e5f12f8c83f553f61c (patch)
tree28087388486f5773f682ffec37ac129893756154
parentdec5fb2d6c514e7ba05859e5816fb77d785b44e6 (diff)
downloadalpine_aports-bcf88ad2c00977427d4bb1e5f12f8c83f553f61c.tar.bz2
alpine_aports-bcf88ad2c00977427d4bb1e5f12f8c83f553f61c.tar.xz
alpine_aports-bcf88ad2c00977427d4bb1e5f12f8c83f553f61c.zip
community/whois: fix CFLAGS
* fixes https://gitlab.alpinelinux.org/alpine/aports/-/issues/11998 for reference whois now builds with: gcc -Os -fomit-frame-pointer -DHAVE_GETOPT_LONG -DHAVE_GETADDRINFO -DHAVE_SHA_CRYPT -Wl,--as-needed -o whois whois.o utils.o simple_recode.o -lidn -lintl
-rw-r--r--community/whois/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/whois/APKBUILD b/community/whois/APKBUILD
index b46481f2f4..aab35c8cc4 100644
--- a/community/whois/APKBUILD
+++ b/community/whois/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Stuart Cardall <developer@it-offshore.co.uk> 2# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
3pkgname=whois 3pkgname=whois
4pkgver=5.5.7 4pkgver=5.5.7
5pkgrel=0 5pkgrel=1
6pkgdesc="Intelligent WHOIS client by Marco d'Itri" 6pkgdesc="Intelligent WHOIS client by Marco d'Itri"
7url="https://github.com/rfc1036/whois" 7url="https://github.com/rfc1036/whois"
8arch="all" 8arch="all"
@@ -16,6 +16,7 @@ source="$pkgver-$pkgver.tar.gz::https://github.com/rfc1036/whois/archive/v$pkgve
16 " 16 "
17 17
18build() { 18build() {
19 export CFLAGS="$CFLAGS -DHAVE_GETOPT_LONG -DHAVE_GETADDRINFO -DHAVE_SHA_CRYPT"
19 make CONFIG_FILE="/etc/whois.conf" HAVE_ICONV=1 20 make CONFIG_FILE="/etc/whois.conf" HAVE_ICONV=1
20} 21}
21 22