aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-01-28 15:38:27 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-01-28 15:44:54 +0100
commitc3d9b869674fc250fe4d09f3858ae768130a9c83 (patch)
tree607bbc189f67294b129a5b775ce8c3a057ad361d
parentdc2d673ef1895012f653c35bf6ef0e51f6dec260 (diff)
downloadalpine_aports-c3d9b869674fc250fe4d09f3858ae768130a9c83.tar.bz2
alpine_aports-c3d9b869674fc250fe4d09f3858ae768130a9c83.tar.xz
alpine_aports-c3d9b869674fc250fe4d09f3858ae768130a9c83.zip
main/liblognorm: new aport (needed for main/rsyslog)
http://www.liblognorm.com A fast log-normalization library
-rw-r--r--main/liblognorm/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/liblognorm/APKBUILD b/main/liblognorm/APKBUILD
new file mode 100644
index 0000000000..76107ca256
--- /dev/null
+++ b/main/liblognorm/APKBUILD
@@ -0,0 +1,38 @@
1# Contributor: Jakub Jirutka <jakub@jirutka.cz>
2# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
3pkgname=liblognorm
4pkgver=2.0.6
5pkgrel=0
6pkgdesc="A fast log-normalization library"
7url="http://www.liblognorm.com"
8arch="all"
9license="LGPL-2.1-or-later Apache-2.0"
10depends_dev="libestr-dev"
11checkdepends="bash"
12makedepends="$depends_dev libfastjson-dev"
13subpackages="$pkgname-dev"
14source="http://www.liblognorm.com/files/download/$pkgname-$pkgver.tar.gz"
15builddir="$srcdir/$pkgname-$pkgver"
16
17build() {
18 cd "$builddir"
19 ./configure \
20 --build=$CBUILD \
21 --host=$CHOST \
22 --prefix=/usr \
23 --mandir=/usr/share/man \
24 --enable-testbench
25 make
26}
27
28check() {
29 cd "$builddir"
30 make -j1 check
31}
32
33package() {
34 cd "$builddir"
35 make DESTDIR="$pkgdir" install
36}
37
38sha512sums="0b4ee55eb54920dd096fdd6d6dcc2263bc52e74442d86503bfebf26b31492a8c1b67cb3b709ecc8b96cc53252151515719027306b2b6f7ba3404adc5a48cf125 liblognorm-2.0.6.tar.gz"