aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-14 13:01:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-14 13:01:16 +0000
commitcaa1bf9276c2b9a7c1180b10812a0ba2621c2cc1 (patch)
tree9f97ba90f5b70dd73e868ea4407ec15b3f3d9ff8
parentabb314d550cd23f6ad4a8625e0e0b3865fdb9642 (diff)
downloadalpine_aports-caa1bf9276c2b9a7c1180b10812a0ba2621c2cc1.tar.bz2
alpine_aports-caa1bf9276c2b9a7c1180b10812a0ba2621c2cc1.tar.xz
alpine_aports-caa1bf9276c2b9a7c1180b10812a0ba2621c2cc1.zip
testing/pidgin-otr: new aport
Off The Record Messaging, an encryption plugin for pidgin to provide secure IM conversations http://otr.cypherpunks.ca/
-rw-r--r--testing/pidgin-otr/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/pidgin-otr/APKBUILD b/testing/pidgin-otr/APKBUILD
new file mode 100644
index 0000000000..2020cf907b
--- /dev/null
+++ b/testing/pidgin-otr/APKBUILD
@@ -0,0 +1,40 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=pidgin-otr
3pkgver=4.0.0
4pkgrel=0
5pkgdesc="Off The Record Messaging, an encryption plugin for pidgin to provide secure IM conversations"
6url="http://otr.cypherpunks.ca/"
7arch="all"
8license="LGPL"
9depends="pidgin"
10makedepends="libotr-dev gtk+-dev intltool pidgin-dev"
11install=
12subpackages="$pkgname-lang"
13source="http://www.cypherpunks.ca/otr/$pkgname-$pkgver.tar.gz"
14
15_builddir="$srcdir/$pkgname-$pkgver"
16prepare() {
17 local i
18 cd "$_builddir"
19 for i in $source; do
20 case $i in
21 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
22 esac
23 done
24}
25
26build() {
27 cd "$_builddir"
28 ./configure --prefix=/usr
29 make || return 1
30}
31
32package() {
33 cd "$_builddir"
34 make DESTDIR="$pkgdir" install || return 1
35 rm "$pkgdir"/usr/lib/pidgin/*.la || return 1
36}
37
38md5sums="eadb953376acc474e56041d4c12aa2c8 pidgin-otr-4.0.0.tar.gz"
39sha256sums="d56b3f092dbe9ee6597641c7d2dd294884dc04ba47aaf4ec571cd54977df4691 pidgin-otr-4.0.0.tar.gz"
40sha512sums="5f74da77d0c72576bb4a510b41bc70f041ab2555554b4d37376073f2edee8e1021c153cf5cc3d32bd276bdee643e9e7d881026628240a8757e5f8974c200f3d7 pidgin-otr-4.0.0.tar.gz"