aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-04-15 13:04:54 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-04-15 13:04:54 +0000
commitdaade37f581f834e4b08dac4a9e270c95c7c971d (patch)
tree696ee531451681eed36ac3753292f2bbbd198030
parent4ee2c8e21214be09406937ad4018465b94fa499f (diff)
downloadalpine_aports-daade37f581f834e4b08dac4a9e270c95c7c971d.tar.bz2
alpine_aports-daade37f581f834e4b08dac4a9e270c95c7c971d.tar.xz
alpine_aports-daade37f581f834e4b08dac4a9e270c95c7c971d.zip
testing/py-hoedown: new aport
-rw-r--r--testing/py-hoedown/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-hoedown/APKBUILD b/testing/py-hoedown/APKBUILD
new file mode 100644
index 0000000000..6ecdbfe6dc
--- /dev/null
+++ b/testing/py-hoedown/APKBUILD
@@ -0,0 +1,31 @@
1# Maintainer: Eivind Uggedal <eivind@uggedal.com>
2pkgname=py-hoedown
3_pkgname=hoedown
4pkgver=0.2
5pkgrel=0
6pkgdesc="Python binding for hoedown, a markdown parsing library"
7url="https://github.com/hhatto/python-hoedown"
8arch="all"
9license="MIT"
10depends="python"
11depends_dev=""
12makedepends="python-dev py-setuptools"
13install=""
14subpackages=""
15source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
16
17_builddir="$srcdir"/$_pkgname-$pkgver
18
19build() {
20 cd "$_builddir"
21 python setup.py build
22}
23
24package() {
25 cd "$_builddir"
26 python setup.py install --prefix=/usr --root="$pkgdir"
27}
28
29md5sums="76f56e222a52e0b575bba5274cd6bddf hoedown-0.2.tar.gz"
30sha256sums="b3f3b4885a63c545805cbc2ecf72036649623b60b97dcdc46348293bc7bf0ed3 hoedown-0.2.tar.gz"
31sha512sums="a3f872571c84665de24c594040ca72311e1dbac40f14c099f67de7b6bf3a30b4d6616b5b489a00280e5f08441d70a5774787fd39e059aea10b65cc89828cb7c1 hoedown-0.2.tar.gz"