aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-21 14:23:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-21 14:23:15 +0000
commitf0da2a7793f17fdca10df09ca568cea681f53d31 (patch)
tree1b398d6b12a714fa850d7e55979ba33bb5253106
parentda7d55d04ef1a98f44cdff112afdde3dda7810f6 (diff)
downloadalpine_aports-f0da2a7793f17fdca10df09ca568cea681f53d31.tar.bz2
alpine_aports-f0da2a7793f17fdca10df09ca568cea681f53d31.tar.xz
alpine_aports-f0da2a7793f17fdca10df09ca568cea681f53d31.zip
main/libc0.9.32: add fix from upstream
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/uclibc-resolv-fix-memory-leak.patch33
2 files changed, 36 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index acb107f370..cbf5aa3392 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
4_gitver= 4_gitver=
5pkgver=0.9.32 5pkgver=0.9.32
6_ver=${pkgver/_/-} 6_ver=${pkgver/_/-}
7pkgrel=3 7pkgrel=4
8pkgdesc="C library for developing embedded Linux systems" 8pkgdesc="C library for developing embedded Linux systems"
9url=http://uclibc.org 9url=http://uclibc.org
10license="LGPL-2" 10license="LGPL-2"
@@ -22,6 +22,7 @@ _snapfile="$pkgname-$pkgver.tar.bz2"
22source="http://uclibc.org/downloads/uClibc-${_ver}.tar.bz2 22source="http://uclibc.org/downloads/uClibc-${_ver}.tar.bz2
23 compat-stack-guard.patch 23 compat-stack-guard.patch
24 uclibc-resolv-cname-fix.diff 24 uclibc-resolv-cname-fix.diff
25 uclibc-resolv-fix-memory-leak.patch
25 0001-resolv-fix-resolver-to-return-TRY_AGAIN-on-timeout.patch 26 0001-resolv-fix-resolver-to-return-TRY_AGAIN-on-timeout.patch
26 0001-libm-x86_64-implement-some-fenv-functions.patch 27 0001-libm-x86_64-implement-some-fenv-functions.patch
27 0001-ldso-limited-support-for-ORIGIN-in-rpath.patch 28 0001-ldso-limited-support-for-ORIGIN-in-rpath.patch
@@ -130,6 +131,7 @@ libthread_db() {
130md5sums="cfcb6c25d8ebe12817499d8749ee8ae1 uClibc-0.9.32.tar.bz2 131md5sums="cfcb6c25d8ebe12817499d8749ee8ae1 uClibc-0.9.32.tar.bz2
131a9bfb77ea7dc5fb9abf4d4b19201c614 compat-stack-guard.patch 132a9bfb77ea7dc5fb9abf4d4b19201c614 compat-stack-guard.patch
1325d6e3e382b66f59cfd7242a4fe453f98 uclibc-resolv-cname-fix.diff 1335d6e3e382b66f59cfd7242a4fe453f98 uclibc-resolv-cname-fix.diff
1346bdb884bd00b053247e02b4024d33b39 uclibc-resolv-fix-memory-leak.patch
13308f31006426a0fca561f262f36bcfb01 0001-resolv-fix-resolver-to-return-TRY_AGAIN-on-timeout.patch 13508f31006426a0fca561f262f36bcfb01 0001-resolv-fix-resolver-to-return-TRY_AGAIN-on-timeout.patch
13468913d6f096fd647e8bdb7ef182c05a4 0001-libm-x86_64-implement-some-fenv-functions.patch 13668913d6f096fd647e8bdb7ef182c05a4 0001-libm-x86_64-implement-some-fenv-functions.patch
135bc164e262c5feab55c800780704fa71c 0001-ldso-limited-support-for-ORIGIN-in-rpath.patch 137bc164e262c5feab55c800780704fa71c 0001-ldso-limited-support-for-ORIGIN-in-rpath.patch
diff --git a/main/libc0.9.32/uclibc-resolv-fix-memory-leak.patch b/main/libc0.9.32/uclibc-resolv-fix-memory-leak.patch
new file mode 100644
index 0000000000..8738ba7745
--- /dev/null
+++ b/main/libc0.9.32/uclibc-resolv-fix-memory-leak.patch
@@ -0,0 +1,33 @@
1From bb8d500a75a3050fe3198773ce7b07f669fe8f13 Mon Sep 17 00:00:00 2001
2From: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
3Date: Fri, 14 Oct 2011 15:47:42 +0000
4Subject: resolv: fix memory leak
5
6Timothy Holdener writes:
7small memory leak in __dns_lookup() when the A record
8in the DNS answer is preceded by one or more CNAME records.
9
10Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
11---
12diff --git a/libc/inet/resolv.c b/libc/inet/resolv.c
13index 38254bd..e415d30 100644
14--- a/libc/inet/resolv.c
15+++ b/libc/inet/resolv.c
16@@ -1507,6 +1507,7 @@ int attribute_hidden __dns_lookup(const char *name,
17 DPRINTF("Decoding answer at pos %d\n", pos);
18
19 first_answer = 1;
20+ a->dotted = NULL;
21 for (j = 0; j < h.ancount; j++) {
22 i = __decode_answer(packet, pos, packet_len, &ma);
23 if (i < 0) {
24@@ -1523,6 +1524,7 @@ int attribute_hidden __dns_lookup(const char *name,
25 ma.buf = a->buf;
26 ma.buflen = a->buflen;
27 ma.add_count = a->add_count;
28+ free(a->dotted);
29 memcpy(a, &ma, sizeof(ma));
30 if (a->atype != T_SIG && (NULL == a->buf || (type != T_A && type != T_AAAA)))
31 break;
32--
33cgit v0.9.0.1-2-gef13