aboutsummaryrefslogtreecommitdiff
path: root/community/frotz
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2020-07-18 23:20:18 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-07-19 03:45:21 +0000
commit834412e41b6c321b8c7223c57ad1b9865ca03703 (patch)
tree925dafcef0573dbb1f578c2ae23bfba007be472e /community/frotz
parent508de7539866f96eb05d3e918d66fe313b1c6101 (diff)
downloadalpine_aports-834412e41b6c321b8c7223c57ad1b9865ca03703.tar.bz2
alpine_aports-834412e41b6c321b8c7223c57ad1b9865ca03703.tar.xz
alpine_aports-834412e41b6c321b8c7223c57ad1b9865ca03703.zip
community/frotz: upgrade to 2.52
* Update source url to new upstream. * Remove uneeded patch and use our own CFLAGS.
Diffstat (limited to 'community/frotz')
-rw-r--r--community/frotz/APKBUILD26
-rw-r--r--community/frotz/Makefile.patch49
2 files changed, 13 insertions, 62 deletions
diff --git a/community/frotz/APKBUILD b/community/frotz/APKBUILD
index 84ef7be19c..6852182a59 100644
--- a/community/frotz/APKBUILD
+++ b/community/frotz/APKBUILD
@@ -1,29 +1,29 @@
1# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to> 1# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
2# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to> 2# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
3pkgname=frotz 3pkgname=frotz
4pkgver=2.44 4pkgver=2.52
5pkgrel=1 5pkgrel=0
6pkgdesc="Portable Z-Machine Interpreter" 6pkgdesc="Portable Z-Machine Interpreter"
7url="http://frotz.sourceforge.net/" 7url="http://frotz.sourceforge.net/"
8arch="all" 8arch="all"
9license="GPL-2.0-or-later" 9license="GPL-2.0-or-later"
10makedepends="ncurses-dev" 10makedepends="libao-dev libmodplug-dev libsamplerate-dev libsndfile-dev
11 ncurses-dev"
11subpackages="$pkgname-doc" 12subpackages="$pkgname-doc"
12source="$pkgname-$pkgver.tar.gz::https://github.com/DavidGriffith/frotz/archive/$pkgver.tar.gz 13source="https://gitlab.com/DavidGriffith/frotz/-/archive/$pkgver/frotz-$pkgver.tar.bz2"
13 Makefile.patch 14
14 " 15prepare() {
16 default_prepare
17 # use our cflags
18 sed -i 's/^CFLAGS +=/CFLAGS ?=/g' Makefile
19}
15 20
16build() { 21build() {
17 make 22 make
18} 23}
19 24
20package() { 25package() {
21 strip $pkgname 26 make DESTDIR="$pkgdir" PREFIX=/usr install
22 install -m755 -d "$pkgdir/usr/bin"
23 install -m755 -d "$pkgdir/usr/share/man/man6"
24 install -m755 $pkgname "$pkgdir/usr/bin/"
25 install -m644 doc/$pkgname.6 $pkgdir/usr/share/man/man6/$pkgname.6
26} 27}
27 28
28sha512sums="20b2c8948f093463c53498b322230881aa1ad9c8fd68a338b4f5c4803ab28007fc8ba63f6d20f2b4d440fd04138709b9f4f103c9f8a71788e80156ccdff9ce1f frotz-2.44.tar.gz 29sha512sums="387e7a7fe0cffd40b639a306eef89a22421a4ff4a8e5dbcf96a1ef3b901744b3f75a671953ecdc17bde0d699e4756d470b61c8213c47315baa2700da92d06710 frotz-2.52.tar.bz2"
2950bd0db62eb09bb316dbab106d2bba0ad389e151fefbc587dbd15faf238b559276ce9d603333d5da8760623d014e2587609b96401e616f22062cb0a6aaa2f346 Makefile.patch"
diff --git a/community/frotz/Makefile.patch b/community/frotz/Makefile.patch
deleted file mode 100644
index ead06f88d0..0000000000
--- a/community/frotz/Makefile.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1--- src/frotz-2.43d/Makefile 2012-01-03 08:32:58.000000000 +0000
2+++ ../Makefile 2014-12-01 13:08:50.390040011 +0000
3@@ -14,19 +14,19 @@
4 #-malign-jumps=2
5
6 # Define where you want Frotz installed. Usually this is /usr/local
7-PREFIX = /usr/local
8+PREFIX = /usr
9
10-MAN_PREFIX = $(PREFIX)
11-#MAN_PREFIX = /usr/local/share
12+#MAN_PREFIX = $(PREFIX)
13+MAN_PREFIX = /usr/share
14
15-CONFIG_DIR = $(PREFIX)/etc
16-#CONFIG_DIR = /etc
17+#CONFIG_DIR = $(PREFIX)/etc
18+CONFIG_DIR = /etc
19
20 # Define where you want Frotz to look for frotz.conf.
21 #
22-CONFIG_DIR = /usr/local/etc
23-#CONFIG_DIR = /etc
24-#CONFIG_DIR = /usr/pkg/etc
25+#CONFIG_DIR = /usr/local/etc
26+#CONFIG_DIR = /etc
27+#CONFIG_DIR = /usr/pkg/etc
28 #CONFIG_DIR =
29
30 # Uncomment this if you want color support. Most, but not all curses
31@@ -73,15 +73,15 @@
32 # curses library won't work, comment out the first option and uncomment
33 # the second.
34 #
35-CURSES = -lcurses
36-#CURSES = -lncurses
37+#CURSES = -lcurses
38+CURSES = -lncurses
39
40 # Uncomment this if your need to use ncurses instead of the
41 # vendor-supplied curses library. This just tells the compile process
42 # which header to include, so don't worry if ncurses is all you have
43 # (like on Linux). You'll be fine.
44 #
45-#CURSES_DEF = -DUSE_NCURSES_H
46+CURSES_DEF = -DUSE_NCURSES_H
47
48 # Uncomment this if you're compiling Unix Frotz on a machine that lacks
49 # the memmove(3) system call. If you don't know what this means, leave it