aboutsummaryrefslogtreecommitdiff
path: root/community/html2text
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-06-21 20:50:29 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-06-21 20:50:36 +0000
commit5e167c5c3ab647c4976000706d47b976fe12e9c7 (patch)
tree4f5109ab9d72b4b90848d0f245716cf74585d3f0 /community/html2text
parent944d9f505d7759f4745118dc3f4b09804ce907f7 (diff)
downloadalpine_aports-5e167c5c3ab647c4976000706d47b976fe12e9c7.tar.bz2
alpine_aports-5e167c5c3ab647c4976000706d47b976fe12e9c7.tar.xz
alpine_aports-5e167c5c3ab647c4976000706d47b976fe12e9c7.zip
community/html2text: upgrade to 2.0.0
Diffstat (limited to 'community/html2text')
-rw-r--r--community/html2text/APKBUILD31
-rw-r--r--community/html2text/path-config.patch18
2 files changed, 22 insertions, 27 deletions
diff --git a/community/html2text/APKBUILD b/community/html2text/APKBUILD
index 6b122d6103..8be7108085 100644
--- a/community/html2text/APKBUILD
+++ b/community/html2text/APKBUILD
@@ -1,34 +1,31 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org> 1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org> 2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname=html2text 3pkgname=html2text
4pkgver=1.3.2a 4pkgver=2.0.0
5pkgrel=0 5pkgrel=0
6pkgdesc="html2text is a command line utility, written in C++, that converts HTML documents into plain text." 6pkgdesc="html2text is a command line utility, written in C++, that converts HTML documents into plain text."
7url="http://www.mbayer.de/html2text/" 7url="http://www.mbayer.de/html2text/"
8arch="all" 8arch="all"
9license="GPL" 9license="GPL"
10depends="" 10makedepends="bison bash"
11depends_dev=""
12makedepends="$depends_dev bison"
13install=""
14subpackages="$pkgname-doc" 11subpackages="$pkgname-doc"
15source="$pkgname-$pkgver.tar.gz::https://github.com/marado/$pkgname/archive/${pkgver}-17.tar.gz 12source="$pkgname-$pkgver.tar.gz::https://github.com/grobian/html2text/archive/v$pkgver.tar.gz
16 path-config.patch" 13path-config.patch"
17
18builddir="$srcdir"/$pkgname-${pkgver}-17
19 14
20build() { 15build() {
21 cd "$builddir"
22 ./configure --prefix=/usr 16 ./configure --prefix=/usr
23 make || return 1 17 make
18}
19
20check() {
21 make check
24} 22}
25 23
26package() { 24package() {
27 cd "$builddir" 25 install -Dm755 "html2text" "$pkgdir"/usr/bin/html2text
28 install -Dpm755 'html2text' "${pkgdir}/usr/bin/html2text" 26 install -Dm644 "html2text.1" "$pkgdir"/usr/share/man/man1/html2text.1
29 install -Dpm644 'html2text.1.gz' "${pkgdir}/usr/share/man/man1/html2text.1.gz" 27 install -Dm644 "html2textrc.5" "$pkgdir"/usr/share/man/man5/html2textrc.5
30 install -Dpm644 'html2textrc.5.gz' "${pkgdir}/usr/share/man/man5/html2textrc.5.gz"
31} 28}
32 29
33sha512sums="fac0e06211f699ea69cd9c9ea9347758e57402e56aba64cfa3a46446f1278e4ffc6953c7b3fef5ed5617200fda7c57a81d26dec9eb6f3e58d8223a1631b28dd9 html2text-1.3.2a.tar.gz 30sha512sums="94f2cf3f5085307cc2cf5e264b35621029e57142d6e4d832eee2c447860338c947687be5e8c81367696b0b04432a44537a1545a820991c621b4036393ad6f4e8 html2text-2.0.0.tar.gz
34bf4387d12727016c40d9cbad3b4896443f1253071eba6b2f929435164b1d3cb4adbd3d5b8db3f0905a7b7b7e4468be274e950b704179ef6f083810903fb1aa84 path-config.patch" 31940d8cd8247250ad01d604e2ef44b95352a8114247c473ec8472485c5360143ac2218b6deebfedf85d065a23865ae5028eaaf4bd5ac61090643af813515bff99 path-config.patch"
diff --git a/community/html2text/path-config.patch b/community/html2text/path-config.patch
index 6c88ef3d56..72fec7c28a 100644
--- a/community/html2text/path-config.patch
+++ b/community/html2text/path-config.patch
@@ -1,15 +1,13 @@
1diff --git a/Makefile.in b/Makefile.in 1diff --git a/Makefile.in b/Makefile.in
2index e1a9f27..1feb56f 100644 2index 57e1ff8..bc07770 100644
3--- a/Makefile.in 3--- a/Makefile.in
4+++ b/Makefile.in 4+++ b/Makefile.in
5@@ -29,8 +29,8 @@ BISONXX = bison++ 5@@ -32,7 +32,7 @@ BISON = bison
6 YFLAGS = 6 YFLAGS =
7 7
8 INSTALLER = install 8 INSTALLER = install
9-BINDIR = /usr/local/bin 9-PREFIX = /usr/local
10-MANDIR = /usr/local/man 10+PREFIX = /usr
11+BINDIR = /usr/bin 11 BINDIR = $(PREFIX)/bin
12+MANDIR = /usr/share/man 12 MANDIR = $(PREFIX)/man
13 DOCDIR = /usr/share/doc/html2text 13 DOCDIR = $(PREFIX)/share/doc/html2text
14
15 CXX = @CXX@