aboutsummaryrefslogtreecommitdiff
path: root/community/libquotient
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-14 17:21:18 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-22 13:19:51 +0000
commit8b7c4d5f922f836a1ed861e31cda841664a85d2b (patch)
treee5adc1e70b9600d3b4e834512b663a1291516734 /community/libquotient
parent9cb545d7d16d4188dec930411918bc5751c81cc3 (diff)
downloadalpine_aports-8b7c4d5f922f836a1ed861e31cda841664a85d2b.tar.bz2
alpine_aports-8b7c4d5f922f836a1ed861e31cda841664a85d2b.tar.xz
alpine_aports-8b7c4d5f922f836a1ed861e31cda841664a85d2b.zip
community/libquotient: move from testing
Diffstat (limited to 'community/libquotient')
-rw-r--r--community/libquotient/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/libquotient/APKBUILD b/community/libquotient/APKBUILD
new file mode 100644
index 0000000000..64048e6913
--- /dev/null
+++ b/community/libquotient/APKBUILD
@@ -0,0 +1,32 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
2# Maintainer: Bart Ribbers <bribbers@disroot.org>
3pkgname=libquotient
4pkgver=0.5.3.2_git20200814
5pkgrel=0
6_commit="58dfe74390ebdd8ec6611d3b8fecfe7d051ff955"
7pkgdesc="Qt5 library for cross-platform clients for Matrix"
8url="https://github.com/quotient-im/libQuotient"
9arch="all !armhf" # blocked by qt5-qtmultimedia
10license="LGPL-2.1-or-later"
11depends_dev="qt5-qtbase-dev qt5-qtmultimedia-dev libqtolm-dev"
12makedepends="$depends_dev cmake"
13subpackages="$pkgname-dev"
14source="https://github.com/quotient-im/libQuotient/archive/$_commit/libQuotient-$_commit.tar.gz"
15options="!check" # No testsuite
16builddir="$srcdir/libQuotient-$_commit"
17
18build() {
19 cmake -B build \
20 -DCMAKE_BUILD_TYPE=None \
21 -DCMAKE_INSTALL_PREFIX=/usr \
22 -DCMAKE_INSTALL_LIBDIR=lib \
23 -DBUILD_SHARED_LIBS=True \
24 -DQuotient_ENABLE_E2EE=True
25 make -C build
26}
27
28package() {
29 DESTDIR="$pkgdir" make -C build install
30}
31
32sha512sums="f812a230f969113f14b95df534002a1ce3957b90045197ed7789679bd92fd583b700436f8063f7bbc596bd962ff70e2b72a7f8ded7096f78e4ebc6e9559af10c libQuotient-58dfe74390ebdd8ec6611d3b8fecfe7d051ff955.tar.gz"