aboutsummaryrefslogtreecommitdiff
path: root/community/libselinux
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 22:02:29 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 22:02:29 +0000
commitc3e685320315cf6d88cccaef50b6f669e6483bde (patch)
tree266af5d8744901feb19ba66137b145b27f116e09 /community/libselinux
parent8748c10f3feda5ab036620a064826b6242e90d89 (diff)
downloadalpine_aports-c3e685320315cf6d88cccaef50b6f669e6483bde.tar.bz2
alpine_aports-c3e685320315cf6d88cccaef50b6f669e6483bde.tar.xz
alpine_aports-c3e685320315cf6d88cccaef50b6f669e6483bde.zip
community/libselinux: upgrade to 2.8
Diffstat (limited to 'community/libselinux')
-rw-r--r--community/libselinux/0001-libselinux-allow-link-with-lfts.patch40
-rw-r--r--community/libselinux/APKBUILD16
2 files changed, 7 insertions, 49 deletions
diff --git a/community/libselinux/0001-libselinux-allow-link-with-lfts.patch b/community/libselinux/0001-libselinux-allow-link-with-lfts.patch
deleted file mode 100644
index 744bc4222a..0000000000
--- a/community/libselinux/0001-libselinux-allow-link-with-lfts.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 79e346397327277ab793868e2f9d4a29525b6bf3 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Tue, 21 Feb 2017 19:50:18 +0100
4Subject: [PATCH] libselinux: allow link with -lfts
5
6This makes it possible to build libselinux with the external libtfs for
7systems which does not implement the non-standard fts. For example musl
8libc.
9
10 make FTS_LDFLAGS=-lfts
11
12Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
13---
14 libselinux/src/Makefile | 3 ++-
15 1 file changed, 2 insertions(+), 1 deletion(-)
16
17diff --git a/libselinux/src/Makefile b/libselinux/src/Makefile
18index 5640a57..513a9e7 100644
19--- a/src/Makefile
20+++ b/src/Makefile
21@@ -92,6 +92,7 @@ LD_SONAME_FLAGS=-install_name,$(LIBSO)
22 endif
23
24 PCRE_LDFLAGS ?= -lpcre
25+FTS_LDFLAGS ?=
26
27 override CFLAGS += -I../include -I$(INCLUDEDIR) -D_GNU_SOURCE $(DISABLE_FLAGS) $(PCRE_CFLAGS)
28
29@@ -143,7 +144,7 @@ $(LIBA): $(OBJS)
30 $(RANLIB) $@
31
32 $(LIBSO): $(LOBJS)
33- $(CC) $(CFLAGS) -shared -o $@ $^ $(PCRE_LDFLAGS) -ldl $(LDFLAGS) -L$(LIBDIR) -Wl,$(LD_SONAME_FLAGS)
34+ $(CC) $(CFLAGS) -shared -o $@ $^ $(PCRE_LDFLAGS) $(FTS_LDFLAGS) -ldl $(LDFLAGS) -L$(LIBDIR) -Wl,$(LD_SONAME_FLAGS)
35 ln -sf $@ $(TARGET)
36
37 $(LIBPC): $(LIBPC).in ../VERSION
38--
392.11.1
40
diff --git a/community/libselinux/APKBUILD b/community/libselinux/APKBUILD
index 6e70975b29..baffe4dbfd 100644
--- a/community/libselinux/APKBUILD
+++ b/community/libselinux/APKBUILD
@@ -1,30 +1,28 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=libselinux 2pkgname=libselinux
3pkgver=2.6 3pkgver=2.8
4pkgrel=1 4pkgrel=0
5pkgdesc="SELinux library and simple utilities" 5pkgdesc="SELinux library and simple utilities"
6url="https://github.com/SELinuxProject/selinux/wiki" 6url="https://github.com/SELinuxProject/selinux/wiki"
7arch="all" 7arch="all"
8license="Public-Domain" 8license="Public-Domain"
9depends=""
10depends_dev=""
11# we need coreutils for ln --relative 9# we need coreutils for ln --relative
12makedepends="$depends_dev pcre-dev linux-headers libsepol-dev fts-dev coreutils" 10makedepends="pcre-dev linux-headers libsepol-dev fts-dev coreutils"
13install="" 11install=""
14subpackages="$pkgname-dev $pkgname-doc $pkgname-utils" 12subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
15source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/libselinux-$pkgver.tar.gz 13source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/libselinux-$pkgver.tar.gz
16 " 14 "
17 15
18builddir="$srcdir/libselinux-$pkgver" 16builddir="$srcdir/libselinux-$pkgver"
19 17
20build() { 18build() {
21 cd "$builddir" 19 cd "$builddir"
22 make PCRE_LDFLAGS="-lpcre -lfts" || return 1 20 make PCRE_LDLIBS="-lpcre -lfts"
23} 21}
24 22
25package() { 23package() {
26 cd "$builddir" 24 cd "$builddir"
27 make DESTDIR="$pkgdir" install || return 1 25 make DESTDIR="$pkgdir" install
28} 26}
29 27
30utils() { 28utils() {
@@ -33,4 +31,4 @@ utils() {
33 mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/ 31 mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
34} 32}
35 33
36sha512sums="906e1bf98c669862ab4f4e883d511db8d739a5763dc857c9405ad3cc6c70766a482853d07134698a1a98257a8632cc756d0549a7640c2915d051714f502ff14b libselinux-2.6.tar.gz" 34sha512sums="2f15d08888fbef9b0cf7bf01893b513edc6738974e2d0eab7e3f79cef9be79cf966742b0d2693b5d2ec7defddb5f4d6c6f6280be9d4158ed41f7a18d50b9f019 libselinux-2.8.tar.gz"