aboutsummaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2020-10-05 10:24:01 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-10-10 02:01:15 +0000
commitba79957f4ad81ef72a017bd6c5b53876f1a174a6 (patch)
tree2a528379a94047c103c00bdf3a52c7f9eb4ac4a8 /community
parenta5f5d08084f891f7b206d248f9fee7369e812d98 (diff)
downloadalpine_aports-ba79957f4ad81ef72a017bd6c5b53876f1a174a6.tar.bz2
alpine_aports-ba79957f4ad81ef72a017bd6c5b53876f1a174a6.tar.xz
alpine_aports-ba79957f4ad81ef72a017bd6c5b53876f1a174a6.zip
community/binutils-avr: Drop package
community/binutils-cross-embedded now provides binutils-avr
Diffstat (limited to 'community')
-rw-r--r--community/binutils-avr/APKBUILD57
-rw-r--r--community/binutils-avr/binutils-ld-fix-static-linking.patch46
2 files changed, 0 insertions, 103 deletions
diff --git a/community/binutils-avr/APKBUILD b/community/binutils-avr/APKBUILD
deleted file mode 100644
index a147f3d1c0..0000000000
--- a/community/binutils-avr/APKBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
1# Contributor: Stefan Wagner <stw@bit-strickerei.de>
2# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
3pkgname=binutils-avr
4pkgver=2.35.1
5pkgrel=0
6pkgdesc="Tools necessary to build programs for AVR targets"
7url="https://www.gnu.org/software/binutils/"
8makedepends="gettext libtool autoconf automake texinfo"
9arch="all"
10license="GPL-2.0 GPL-3.0-or-later LGPL-2.0 BSD"
11subpackages="$pkgname-doc"
12source="https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz
13 binutils-ld-fix-static-linking.patch"
14
15builddir="$srcdir/binutils-$pkgver"
16_workingdir="$srcdir/binutils-build"
17
18# secfixes:
19# 2.32-r0:
20# - CVE-2018-19931
21# - CVE-2018-19932
22# - CVE-2018-20002
23# - CVE-2018-20712
24
25build() {
26 mkdir "$_workingdir"
27 cd "$_workingdir"
28 "$builddir"/configure \
29 --build="$CBUILD" \
30 --target=avr \
31 --with-lib-path=/usr/lib \
32 --prefix=/usr \
33 --enable-ld=default \
34 --enable-gold=yes \
35 --enable-plugins \
36 --disable-multilib \
37 --disable-werror \
38 --disable-nls
39 make tooldir=/usr
40}
41
42check() {
43 cd "$_workingdir"
44 make check
45}
46
47package() {
48 cd "$_workingdir"
49 make tooldir=/usr install DESTDIR="$pkgdir"
50 rm -rf "$pkgdir"/usr/share/info
51 for bin in ar as nm objcopy objdump ranlib strip readelf; do
52 rm -f "$pkgdir"/usr/bin/"$bin"
53 done
54}
55
56sha512sums="94ff72708403413b70b247f3af4099ebaa882b6659249869f1ed9941a0f1912e313f08357d470f9fd2359e7f5e5b0eb86285e5eaf883fa8187789d6b1bd304eb binutils-2.35.1.tar.xz
57ecee33b0e435aa704af1c334e560f201638ff79e199aa11ed78a72f7c9b46f85fbb227af5748e735fd681d1965fcc42ac81b0c8824e540430ce0c706c81e8b49 binutils-ld-fix-static-linking.patch"
diff --git a/community/binutils-avr/binutils-ld-fix-static-linking.patch b/community/binutils-avr/binutils-ld-fix-static-linking.patch
deleted file mode 100644
index bc5d762656..0000000000
--- a/community/binutils-avr/binutils-ld-fix-static-linking.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1This fixes static linking for our hardened toolchain
2diff --git a/ld/scripttempl/elf.sc b/ld/scripttempl/elf.sc
3index e8126cb..9532bfb 100644
4--- a/ld/scripttempl/elf.sc
5+++ b/ld/scripttempl/elf.sc
6@@ -235,8 +235,8 @@ test "${LARGE_SECTIONS}" = "yes" && LARGE_SECTIONS="
7 if test "${ENABLE_INITFINI_ARRAY}" = "yes"; then
8 SORT_INIT_ARRAY="KEEP (*(SORT_BY_INIT_PRIORITY(.init_array.*) SORT_BY_INIT_PRIORITY(.ctors.*)))"
9 SORT_FINI_ARRAY="KEEP (*(SORT_BY_INIT_PRIORITY(.fini_array.*) SORT_BY_INIT_PRIORITY(.dtors.*)))"
10- CTORS_IN_INIT_ARRAY="EXCLUDE_FILE (*crtbegin.o *crtbegin?.o *crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .ctors"
11- DTORS_IN_FINI_ARRAY="EXCLUDE_FILE (*crtbegin.o *crtbegin?.o *crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .dtors"
12+ CTORS_IN_INIT_ARRAY="EXCLUDE_FILE (*crtbegin*.o *crtend*.o $OTHER_EXCLUDE_FILES) .ctors"
13+ DTORS_IN_FINI_ARRAY="EXCLUDE_FILE (*crtbegin*.o *crtend*.o $OTHER_EXCLUDE_FILES) .dtors"
14 else
15 SORT_INIT_ARRAY="KEEP (*(SORT(.init_array.*)))"
16 SORT_FINI_ARRAY="KEEP (*(SORT(.fini_array.*)))"
17@@ -270,15 +270,14 @@ CTOR=".ctors ${CONSTRUCTING-0} :
18 doesn't matter which directory crtbegin.o
19 is in. */
20
21- KEEP (*crtbegin.o(.ctors))
22- KEEP (*crtbegin?.o(.ctors))
23+ KEEP (*crtbegin*.o(.ctors))
24
25 /* We don't want to include the .ctor section from
26 the crtend.o file until after the sorted ctors.
27 The .ctor section from the crtend file contains the
28 end of ctors marker and it must be last */
29
30- KEEP (*(EXCLUDE_FILE (*crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .ctors))
31+ KEEP (*(EXCLUDE_FILE (*crtend*.o $OTHER_EXCLUDE_FILES) .ctors))
32 KEEP (*(SORT(.ctors.*)))
33 KEEP (*(.ctors))
34 ${CONSTRUCTING+${CTOR_END}}
35@@ -286,9 +285,8 @@ CTOR=".ctors ${CONSTRUCTING-0} :
36 DTOR=".dtors ${CONSTRUCTING-0} :
37 {
38 ${CONSTRUCTING+${DTOR_START}}
39- KEEP (*crtbegin.o(.dtors))
40- KEEP (*crtbegin?.o(.dtors))
41- KEEP (*(EXCLUDE_FILE (*crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .dtors))
42+ KEEP (*crtbegin*.o(.dtors))
43+ KEEP (*(EXCLUDE_FILE (*crtend*.o $OTHER_EXCLUDE_FILES) .dtors))
44 KEEP (*(SORT(.dtors.*)))
45 KEEP (*(.dtors))
46 ${CONSTRUCTING+${DTOR_END}}