aboutsummaryrefslogtreecommitdiff
path: root/main/alpine-conf
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-28 15:32:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-28 15:32:26 +0000
commit59db8f0a62f94c0bb83665c77e55857de416b182 (patch)
tree9be32d54deabd4dbd3718a0c4f7afa11a231cf4a /main/alpine-conf
parente1c51734fa96fa4bac92e9f14a474324c67916fc (diff)
downloadalpine_aports-59db8f0a62f94c0bb83665c77e55857de416b182.tar.bz2
alpine_aports-59db8f0a62f94c0bb83665c77e55857de416b182.tar.xz
alpine_aports-59db8f0a62f94c0bb83665c77e55857de416b182.zip
main/alpine-conf: upgrade to 3.9.0
Diffstat (limited to 'main/alpine-conf')
-rw-r--r--main/alpine-conf/0001-lbu-fix-wrong-cipher-match-in-check_openssl-for-lbu-.patch27
-rw-r--r--main/alpine-conf/0001-libalpine-make-vecho-and-qecho-return-success.patch39
-rw-r--r--main/alpine-conf/0001-libalpine-use-correct-exit-code-in-trap.patch30
-rw-r--r--main/alpine-conf/0001-setup-apkrepos-use-cdn-as-default-answer.patch26
-rw-r--r--main/alpine-conf/0001-setup-disk-let-user-set-ROOT_SIZE.patch37
-rw-r--r--main/alpine-conf/0001-update-kernel-fallback-to-old-dtbdir-if-new-one-does.patch29
-rw-r--r--main/alpine-conf/0001-update-kernel-fix-dtbs-dir.patch36
-rw-r--r--main/alpine-conf/APKBUILD23
8 files changed, 4 insertions, 243 deletions
diff --git a/main/alpine-conf/0001-lbu-fix-wrong-cipher-match-in-check_openssl-for-lbu-.patch b/main/alpine-conf/0001-lbu-fix-wrong-cipher-match-in-check_openssl-for-lbu-.patch
deleted file mode 100644
index 7369c46d49..0000000000
--- a/main/alpine-conf/0001-lbu-fix-wrong-cipher-match-in-check_openssl-for-lbu-.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From ad9996810186cbed04ec0c185bd3c998622a0a4f Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Milan=20P=2E=20Stani=C4=87?= <mps@arvanta.net>
3Date: Thu, 16 Jan 2020 11:09:28 +0100
4Subject: [PATCH] lbu: fix wrong cipher match in check_openssl for 'lbu commit
5 -e'
6
7fixes #10451
8---
9 lbu.in | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/lbu.in b/lbu.in
13index f439cf2..fb4fbe5 100644
14--- a/lbu.in
15+++ b/lbu.in
16@@ -126,7 +126,7 @@ check_openssl() {
17 [ -z "$ENCRYPTION" ] && return 0
18 OPENSSL=$(which openssl 2>/dev/null) || die "openssl was not found"
19
20- $OPENSSL enc -ciphers | grep "^$ENCRYPTION$" > /dev/null \
21+ $OPENSSL list -1 -cipher-commands | grep "^$ENCRYPTION$" > /dev/null \
22 || die "Cipher $ENCRYPTION is not supported"
23 }
24
25--
262.25.0
27
diff --git a/main/alpine-conf/0001-libalpine-make-vecho-and-qecho-return-success.patch b/main/alpine-conf/0001-libalpine-make-vecho-and-qecho-return-success.patch
deleted file mode 100644
index cbc91b2b8d..0000000000
--- a/main/alpine-conf/0001-libalpine-make-vecho-and-qecho-return-success.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 5d90f33f62375f23367d3c5a7badd2d7f1031744 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Fri, 24 Jan 2020 11:49:04 +0000
4Subject: [PATCH] libalpine: make vecho and qecho return success
5
6vecho should return success even if $VERBOSE is empty. Similar, qecho
7should return success even if $QUIET is empty.
8
9fixes !4
10---
11 libalpine.sh.in | 8 ++++++--
12 1 file changed, 6 insertions(+), 2 deletions(-)
13
14diff --git a/libalpine.sh.in b/libalpine.sh.in
15index d7b79fa..0f96b9f 100644
16--- a/libalpine.sh.in
17+++ b/libalpine.sh.in
18@@ -26,12 +26,16 @@ echon () {
19
20 # echo if in verbose mode
21 vecho() {
22- [ -n "$VERBOSE" ] && echo "$@"
23+ if [ -n "$VERBOSE" ]; then
24+ echo "$@"
25+ fi
26 }
27
28 # echo unless quiet mode
29 qecho() {
30- [ -z "$QUIET" ] && echo "$@"
31+ if [ -z "$QUIET" ]; then
32+ echo "$@"
33+ fi
34 }
35
36 # echo to stderr
37--
382.25.0
39
diff --git a/main/alpine-conf/0001-libalpine-use-correct-exit-code-in-trap.patch b/main/alpine-conf/0001-libalpine-use-correct-exit-code-in-trap.patch
deleted file mode 100644
index 5426f62017..0000000000
--- a/main/alpine-conf/0001-libalpine-use-correct-exit-code-in-trap.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 6bcb2c2b0860779dc44d8dd27259f9edc6c9e6e8 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Thu, 21 Nov 2019 16:29:52 +0100
4Subject: [PATCH] libalpine: use correct exit code in trap
5
6save exit state before cleaning up tempdir so we get the correct exit
7code.
8
9This fixes the problem where lbu exit with success on errors where disk
10is full or similar.
11---
12 libalpine.sh.in | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/libalpine.sh.in b/libalpine.sh.in
16index f3857e2..d7b79fa 100644
17--- a/libalpine.sh.in
18+++ b/libalpine.sh.in
19@@ -50,7 +50,7 @@ init_tmpdir() {
20 local __tmpd="/tmp/$PROGRAM-${$}-$(date +%s)-$RANDOM"
21 umask 077 || die "umask"
22 mkdir -p "$__tmpd" || exit 1
23- trap "rm -fr \"$__tmpd\"; exit" 0
24+ trap "rc=\$?; rm -fr \"$__tmpd\"; exit \$rc" 0
25 umask $omask
26 eval "$1=\"$__tmpd\""
27 }
28--
292.24.0
30
diff --git a/main/alpine-conf/0001-setup-apkrepos-use-cdn-as-default-answer.patch b/main/alpine-conf/0001-setup-apkrepos-use-cdn-as-default-answer.patch
deleted file mode 100644
index e37241230f..0000000000
--- a/main/alpine-conf/0001-setup-apkrepos-use-cdn-as-default-answer.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 5358f24b8ba5c359db504421d09fc16cf9e7f8cf Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Wed, 11 Dec 2019 18:01:26 +0000
4Subject: [PATCH] setup-apkrepos: use cdn as default answer
5
6use '1', which should be dl-cdn, as the default answer
7---
8 setup-apkrepos.in | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/setup-apkrepos.in b/setup-apkrepos.in
12index 81e768e..1b05978 100644
13--- a/setup-apkrepos.in
14+++ b/setup-apkrepos.in
15@@ -175,7 +175,7 @@ if [ -r "$APKREPOS_PATH" ]; then
16 fi
17
18 get_alpine_release
19-default_answer=f
20+default_answer=1
21 changed=false
22
23 if [ $# -gt 0 ]; then
24--
252.24.1
26
diff --git a/main/alpine-conf/0001-setup-disk-let-user-set-ROOT_SIZE.patch b/main/alpine-conf/0001-setup-disk-let-user-set-ROOT_SIZE.patch
deleted file mode 100644
index 49d42167a5..0000000000
--- a/main/alpine-conf/0001-setup-disk-let-user-set-ROOT_SIZE.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 93ce697c0075aeb51db9b78c0d47e10213aa1885 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Fri, 6 Dec 2019 15:53:45 +0000
4Subject: [PATCH] setup-disk: let user set ROOT_SIZE
5
6allow user set rootfs size via ROOT_SIZE. For lvm it will be passed
7directly to lvmcreate. For the sfdisk partitions it will be a number in
8MiB.
9---
10 setup-disk.in | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/setup-disk.in b/setup-disk.in
14index 5eb8638..b309919 100644
15--- a/setup-disk.in
16+++ b/setup-disk.in
17@@ -989,7 +989,7 @@ native_disk_install_lvm() {
18
19 setup_lvm_volume_group $vgname $@ || return 1
20 setup_lvm_swap $vgname
21- lvcreate --quiet -n ${root_dev##*/} -l 100%FREE $vgname
22+ lvcreate --quiet -n ${root_dev##*/} -l ${ROOT_SIZE:-100%FREE} $vgname
23 rc-update add lvm boot
24 setup_root $root_dev $BOOT_DEV
25 }
26@@ -1002,7 +1002,7 @@ native_disk_install() {
27 local prep_size=8
28 local boot_size=${BOOT_SIZE:-100}
29 local swap_size=${SWAP_SIZE}
30- local root_size=
31+ local root_size=${ROOT_SIZE}
32 local root_dev= boot_dev= swap_dev=
33 init_progs $(select_bootloader) || return 1
34 confirm_erase $@ || return 1
35--
362.24.0
37
diff --git a/main/alpine-conf/0001-update-kernel-fallback-to-old-dtbdir-if-new-one-does.patch b/main/alpine-conf/0001-update-kernel-fallback-to-old-dtbdir-if-new-one-does.patch
deleted file mode 100644
index 5a11874504..0000000000
--- a/main/alpine-conf/0001-update-kernel-fallback-to-old-dtbdir-if-new-one-does.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 0c0ded1d885431bf4509222368278ec6644bf646 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
3Date: Thu, 16 Apr 2020 15:18:03 +0300
4Subject: [PATCH] update-kernel: fallback to old dtbdir if new one does not
5 exist
6
7This allows running update-kernel on new alpine and to create
8images from stable branch by overriding repository files.
9
10Fixes: 3fd2ce43 "update-kernel: fix dtbs dir"
11---
12 update-kernel.in | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/update-kernel.in b/update-kernel.in
16index 3d13d25..d9b774f 100644
17--- a/update-kernel.in
18+++ b/update-kernel.in
19@@ -265,6 +265,7 @@ KVER_FLAVOR=
20 [ "$FLAVOR" = vanilla ] || KVER_FLAVOR=-$FLAVOR
21 KVER=$(basename $(ls -d $ROOT/lib/modules/*"$KVER_FLAVOR"))
22 DTBDIR=$ROOT/boot/dtbs-$FLAVOR
23+[ -d "$DTBDIR" ] || DTBDIR=$ROOT/usr/lib/linux-$KVER
24 depmod -b $ROOT "$KVER"
25
26
27--
282.26.1
29
diff --git a/main/alpine-conf/0001-update-kernel-fix-dtbs-dir.patch b/main/alpine-conf/0001-update-kernel-fix-dtbs-dir.patch
deleted file mode 100644
index a117698c5f..0000000000
--- a/main/alpine-conf/0001-update-kernel-fix-dtbs-dir.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 3fd2ce439dda613a56e3d130c192040a88817787 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Wed, 18 Dec 2019 15:23:10 +0000
4Subject: [PATCH] update-kernel: fix dtbs dir
5
6---
7 update-kernel.in | 6 +++---
8 1 file changed, 3 insertions(+), 3 deletions(-)
9
10diff --git a/update-kernel.in b/update-kernel.in
11index 0079182..3d13d25 100644
12--- a/update-kernel.in
13+++ b/update-kernel.in
14@@ -264,7 +264,7 @@ fi
15 KVER_FLAVOR=
16 [ "$FLAVOR" = vanilla ] || KVER_FLAVOR=-$FLAVOR
17 KVER=$(basename $(ls -d $ROOT/lib/modules/*"$KVER_FLAVOR"))
18-DTBDIR=$ROOT/usr/lib/linux-$KVER
19+DTBDIR=$ROOT/boot/dtbs-$FLAVOR
20 depmod -b $ROOT "$KVER"
21
22
23@@ -341,8 +341,8 @@ if [ -d "$DTBDIR" ]; then
24 _opwd=$PWD
25 case "$MEDIA,$FLAVOR" in
26 yes,rpi*) _dtb="$DESTDIR/" ;;
27- yes,*) _dtb="$DESTDIR/boot/dtbs" ;;
28- *,*) _dtb="$DESTDIR/dtbs" ;;
29+ yes,*) _dtb="$DESTDIR/boot/dtbs-$FLAVOR" ;;
30+ *,*) _dtb="$DESTDIR/dtbs/dtbs-$FLAVOR" ;;
31 esac
32 mkdir -p "$_dtb"
33 _dtb=$(realpath "$_dtb")
34--
352.24.1
36
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 8dfb8f0cad..39424ad5ae 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,21 +1,13 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=alpine-conf 2pkgname=alpine-conf
3pkgver=3.8.3 3pkgver=3.9.0
4pkgrel=7 4pkgrel=0
5pkgdesc="Alpine configuration management scripts" 5pkgdesc="Alpine configuration management scripts"
6url="https://git.alpinelinux.org/alpine-conf/about" 6url="https://git.alpinelinux.org/alpine-conf/about"
7arch="all" 7arch="all"
8license="MIT" 8license="MIT"
9depends="openrc>=0.24.1-r6 busybox>=1.26.1-r3" 9depends="openrc>=0.24.1-r6 busybox>=1.26.1-r3"
10source="https://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz 10source="https://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.bz2"
11 0001-libalpine-use-correct-exit-code-in-trap.patch
12 0001-setup-disk-let-user-set-ROOT_SIZE.patch
13 0001-setup-apkrepos-use-cdn-as-default-answer.patch
14 0001-update-kernel-fix-dtbs-dir.patch
15 0001-lbu-fix-wrong-cipher-match-in-check_openssl-for-lbu-.patch
16 0001-libalpine-make-vecho-and-qecho-return-success.patch
17 0001-update-kernel-fallback-to-old-dtbdir-if-new-one-does.patch
18 "
19 11
20builddir="$srcdir"/$pkgname-$pkgver 12builddir="$srcdir"/$pkgname-$pkgver
21build() { 13build() {
@@ -31,11 +23,4 @@ package() {
31 done 23 done
32} 24}
33 25
34sha512sums="73bd999b552d266c994cc1535570b86ddd7a7379f3b9e244c4985722f5754b11323a4e677cdae91fa4f0098dadd388eba679a99d98e140354ab7681bb85f9dfa alpine-conf-3.8.3.tar.xz 26sha512sums="c7f7ba8341d7c84aa85f521624de511acbea42337377693099156750462a380e0116c9bde2d3a1595c8942c024f1421e7106566c4c0415c734513ddf5ec08cb2 alpine-conf-3.9.0.tar.bz2"
35b5a4ed4e1507a6dde503edca5bc71c9f26e81e3f85dd01aa3705b300d7e9b9f48b7005250dea3105bef89a688bbf70257290e921d49534f6e6dd8848bb5b2fdb 0001-libalpine-use-correct-exit-code-in-trap.patch
36bf59558e5477929a0692c9ba182b71f7913533b50abd53303be6c47897348c53ec587c27a20442c180564c552f84d90d3c7d700b5f6e2cb4bb0a6ac1a7dafd1d 0001-setup-disk-let-user-set-ROOT_SIZE.patch
37a11e69e18da2c86cb5a419b2fc9db144b7fef4676fb4cd7c33bfe6dbf638adb872f7dd43b5c86fba916e94bdcd2d3c352931c579ea3e3333736c1fc3e5cd22fa 0001-setup-apkrepos-use-cdn-as-default-answer.patch
38e6d7ef82f2c875866dba6c8d18c6b8d9909c0a56081252ff1a1b0bfba2a493a3550377e20fa2975e5b6aa4e52f2607730b7ed158dd419751fad2368d9fa0ece5 0001-update-kernel-fix-dtbs-dir.patch
39d2f961761f237240bb046d9a56c07927d2011b5b62c9d84542d45ac144a09aa08e186efe759d66929a2796e416442db8a339e4bdf9e88643c2bf15f4125fe280 0001-lbu-fix-wrong-cipher-match-in-check_openssl-for-lbu-.patch
408f99efff4f6e3a77b10e4a806ea6cf1ebc81577773314af7d2d8e36b646856a2e5786afbd92841a84af07830e42c7a336c221b1ea97a004963d189767cd348f0 0001-libalpine-make-vecho-and-qecho-return-success.patch
4138547de0594534cccee9dd12ebeaa6a951facb7e320a64af39ad6c33694d1b66925a848d62bef91afe655c26a6bb045d047619b4fd5df345b5407dbeb4540a6d 0001-update-kernel-fallback-to-old-dtbdir-if-new-one-does.patch"