aboutsummaryrefslogtreecommitdiff
path: root/main/bluez
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-20 07:37:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 07:38:52 +0000
commit67566773d498d1209b1f3c09cd1e268b16753712 (patch)
tree17d8b265d2f30ac6a7580ba1f748aef21f8d4e52 /main/bluez
parentbc3c848c80beb38eaa51728896d237a94c2c7f0e (diff)
downloadalpine_aports-67566773d498d1209b1f3c09cd1e268b16753712.tar.bz2
alpine_aports-67566773d498d1209b1f3c09cd1e268b16753712.tar.xz
alpine_aports-67566773d498d1209b1f3c09cd1e268b16753712.zip
main/bluez: split bccmd btmon meshctl and obexd to subpackages
This reduces the size of main bluez package from 3MB to 1.6MB and we avoid the libical and json-c runtime dependencies from main package.
Diffstat (limited to 'main/bluez')
-rw-r--r--main/bluez/APKBUILD30
1 files changed, 27 insertions, 3 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index d6c5a75d5f..15237ba86f 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=bluez 2pkgname=bluez
3pkgver=5.47 3pkgver=5.47
4pkgrel=1 4pkgrel=2
5pkgdesc="Tools for the Bluetooth protocol stack" 5pkgdesc="Tools for the Bluetooth protocol stack"
6url="http://www.bluez.org/" 6url="http://www.bluez.org/"
7arch="all" 7arch="all"
@@ -11,8 +11,8 @@ replaces="udev"
11makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev 11makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev
12 libical-dev readline-dev glib-dev linux-headers 12 libical-dev readline-dev glib-dev linux-headers
13 autoconf automake libtool" 13 autoconf automake libtool"
14subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups 14subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bccmd $pkgname-btmon $pkgname-cups
15 $pkgname-hid2hci $pkgname-deprecated" 15 $pkgname-deprecated $pkgname-hid2hci $pkgname-meshctl $pkgname-obexd"
16source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz 16source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
17 bluetooth.initd 17 bluetooth.initd
18 rfcomm.initd 18 rfcomm.initd
@@ -55,6 +55,18 @@ package() {
55 install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent 55 install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
56} 56}
57 57
58bccmd() {
59 pkgdesc="Bluez utility for the CSR BCCMD interface"
60 mkdir -p "$subpkgdir"/usr/bin
61 mv "$pkgdir"/usr/bin/bccmd "$subpkgdir"/usr/bin/
62}
63
64btmon() {
65 pkgdesc="Bluez bluetooth monitor"
66 mkdir -p "$subpkgdir"/usr/bin
67 mv "$pkgdir"/usr/bin/btmon "$subpkgdir"/usr/bin/
68}
69
58cups() { 70cups() {
59 pkgdesc="Bluez backend for CUPS" 71 pkgdesc="Bluez backend for CUPS"
60 mkdir -p "$subpkgdir"/usr/lib/ 72 mkdir -p "$subpkgdir"/usr/lib/
@@ -81,6 +93,18 @@ deprecated() {
81 "$subpkgdir"/usr/bin/ 93 "$subpkgdir"/usr/bin/
82} 94}
83 95
96meshctl() {
97 pkgdesc="Bluez tool for interacting with bluetooth mesh networks"
98 mkdir -p "$subpkgdir"/usr/bin
99 mv "$pkgdir"/usr/bin/meshctl "$subpkgdir"/usr/bin/
100}
101
102obexd() {
103 pkgdesc="Bluez OBEX daemon"
104 mkdir -p "$subpkgdir"/usr/lib/bluetooth
105 mv "$pkgdir"/usr/lib/bluetooth/obexd "$subpkgdir"/usr/lib/bluetooth
106}
107
84sha512sums="86fa1baae1593d4824038db8418358b0be624c81fc23ee8f96ec08979d309a2377be3924ab53cc0fcb712aec8e696360e9a9f4de4c12cc31b14de5cf495a11a6 bluez-5.47.tar.xz 108sha512sums="86fa1baae1593d4824038db8418358b0be624c81fc23ee8f96ec08979d309a2377be3924ab53cc0fcb712aec8e696360e9a9f4de4c12cc31b14de5cf495a11a6 bluez-5.47.tar.xz
85fc43c78ed248ea412529eed5ae8bb47bacca9bf5b3b10de121ddd4e792c85893561a88be4aa2c6318106e5d2146a721445152d44fa60ca257ca0b4eb87318c1e bluetooth.initd 109fc43c78ed248ea412529eed5ae8bb47bacca9bf5b3b10de121ddd4e792c85893561a88be4aa2c6318106e5d2146a721445152d44fa60ca257ca0b4eb87318c1e bluetooth.initd
868d7b7c8938a2316ce0a855e9bdf1ef8fcdf33d23f4011df828270a088b88b140a19c432e83fef15355d0829e3c86be05b63e7718fef88563254ea239b8dc12ac rfcomm.initd 1108d7b7c8938a2316ce0a855e9bdf1ef8fcdf33d23f4011df828270a088b88b140a19c432e83fef15355d0829e3c86be05b63e7718fef88563254ea239b8dc12ac rfcomm.initd