aboutsummaryrefslogtreecommitdiff
path: root/main/boost
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-31 08:12:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-01-02 11:23:28 +0000
commite2f8697eb6345a45a49f5cb372558f3a60153cac (patch)
treed9f7a543ca3de5b70d8658eee74b57006c53b7ea /main/boost
parent3ed856b1df30d14b89f66cb2150fa94b250b39af (diff)
downloadalpine_aports-e2f8697eb6345a45a49f5cb372558f3a60153cac.tar.bz2
alpine_aports-e2f8697eb6345a45a49f5cb372558f3a60153cac.tar.xz
alpine_aports-e2f8697eb6345a45a49f5cb372558f3a60153cac.zip
main/boost: backport patch from upstream
fixes build issue with ceph
Diffstat (limited to 'main/boost')
-rw-r--r--main/boost/0001-revert-cease-dependence-on-range.patch49
-rw-r--r--main/boost/APKBUILD6
2 files changed, 53 insertions, 2 deletions
diff --git a/main/boost/0001-revert-cease-dependence-on-range.patch b/main/boost/0001-revert-cease-dependence-on-range.patch
new file mode 100644
index 0000000000..a6002074ab
--- /dev/null
+++ b/main/boost/0001-revert-cease-dependence-on-range.patch
@@ -0,0 +1,49 @@
1From 436e1dbe6fcd31523d261d18ad011392f1d6fbbc Mon Sep 17 00:00:00 2001
2From: Oliver Kowalke <oliver.kowalke@gmail.com>
3Date: Sun, 1 Dec 2019 20:40:28 +0100
4Subject: [PATCH] Revert "Cease dependence on Range"
5
6This reverts commit 0c556bb59241e682bbcd3f572815149c5a9b17db.
7
8see #44 (One test fails to compile after boostorg/coroutine submodule updated)
9---
10 boost/coroutine/asymmetric_coroutine.hpp | 12 +++---------
11 1 file changed, 3 insertions(+), 9 deletions(-)
12
13diff --git a/boost/coroutine/asymmetric_coroutine.hpp b/boost/coroutine/asymmetric_coroutine.hpp
14index ea96981..640896f 100644
15--- a/boost/coroutine/asymmetric_coroutine.hpp
16+++ b/boost/coroutine/asymmetric_coroutine.hpp
17@@ -14,6 +14,7 @@
18 #include <boost/assert.hpp>
19 #include <boost/config.hpp>
20 #include <boost/move/move.hpp>
21+#include <boost/range.hpp>
22 #include <boost/throw_exception.hpp>
23 #include <boost/utility/explicit_operator_bool.hpp>
24
25@@ -2354,19 +2355,12 @@ end( push_coroutine< R > & c)
26
27 }
28
29-// forward declaration of Boost.Range traits to break dependency on it
30-template<typename C, typename Enabler>
31-struct range_mutable_iterator;
32-
33-template<typename C, typename Enabler>
34-struct range_const_iterator;
35-
36 template< typename Arg >
37-struct range_mutable_iterator< coroutines::push_coroutine< Arg >, void >
38+struct range_mutable_iterator< coroutines::push_coroutine< Arg > >
39 { typedef typename coroutines::push_coroutine< Arg >::iterator type; };
40
41 template< typename R >
42-struct range_mutable_iterator< coroutines::pull_coroutine< R >, void >
43+struct range_mutable_iterator< coroutines::pull_coroutine< R > >
44 { typedef typename coroutines::pull_coroutine< R >::iterator type; };
45
46 }
47--
482.24.1
49
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index c7314e4954..4796bf0494 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -2,7 +2,7 @@
2pkgname=boost 2pkgname=boost
3pkgver=1.72.0 3pkgver=1.72.0
4_pkgver="${pkgver//./_}" 4_pkgver="${pkgver//./_}"
5pkgrel=0 5pkgrel=1
6pkgdesc="Free peer-reviewed portable C++ source libraries" 6pkgdesc="Free peer-reviewed portable C++ source libraries"
7url="http://www.boost.org/" 7url="http://www.boost.org/"
8arch="all" 8arch="all"
@@ -14,6 +14,7 @@ subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
14source="https://dl.bintray.com/boostorg/release/$pkgver/source/boost_$_pkgver.tar.bz2 14source="https://dl.bintray.com/boostorg/release/$pkgver/source/boost_$_pkgver.tar.bz2
15 boost-1.57.0-python-abi_letters.patch 15 boost-1.57.0-python-abi_letters.patch
16 boost-1.57.0-python-libpython_dep.patch 16 boost-1.57.0-python-libpython_dep.patch
17 0001-revert-cease-dependence-on-range.patch
17 " 18 "
18options="!checkroot" 19options="!checkroot"
19builddir="$srcdir/${pkgname}_$_pkgver" 20builddir="$srcdir/${pkgname}_$_pkgver"
@@ -180,4 +181,5 @@ _pyversion() {
180 181
181sha512sums="63bbd1743e7c904b2e69fdc2eafd1c2a8a30fd70d960dcd366059d0100f000cb605d56cbd9397bb18421631f1c9552a772c434d0f0caddbe56302273f51fd1f6 boost_1_72_0.tar.bz2 182sha512sums="63bbd1743e7c904b2e69fdc2eafd1c2a8a30fd70d960dcd366059d0100f000cb605d56cbd9397bb18421631f1c9552a772c434d0f0caddbe56302273f51fd1f6 boost_1_72_0.tar.bz2
182d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch 183d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch
183132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch" 184132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch
1859b53d2fe2dddd592e43db03c26fadd6c07d4c45a980ae4c775b7a914346a3914f6e0c3ef42dad5e2ea4568afb86c9967e09444ff609cfba1e1d39f4980b22ad6 0001-revert-cease-dependence-on-range.patch"