aboutsummaryrefslogtreecommitdiff
path: root/main/fish
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-08-08 11:57:09 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2015-08-10 13:22:50 +0000
commit765091b9be3071541117fe5565691862c1156826 (patch)
treec4b315a0becf7134d7ece5386f056d3af4b83d5b /main/fish
parent5bc39a7221e1a760864bf5bf409ba60ea3d494c3 (diff)
downloadalpine_aports-765091b9be3071541117fe5565691862c1156826.tar.bz2
alpine_aports-765091b9be3071541117fe5565691862c1156826.tar.xz
alpine_aports-765091b9be3071541117fe5565691862c1156826.zip
main/fish: add /usr/bin/fish to /etc/shells
Diffstat (limited to 'main/fish')
-rw-r--r--main/fish/APKBUILD15
-rw-r--r--main/fish/fish.post-install3
l---------main/fish/fish.post-upgrade1
-rw-r--r--main/fish/fish.pre-deinstall3
4 files changed, 13 insertions, 9 deletions
diff --git a/main/fish/APKBUILD b/main/fish/APKBUILD
index 4d441330c7..bc5f8bba25 100644
--- a/main/fish/APKBUILD
+++ b/main/fish/APKBUILD
@@ -2,29 +2,27 @@
2# Maintainer: William Pitcock <nenolod@dereferenced.org> 2# Maintainer: William Pitcock <nenolod@dereferenced.org>
3pkgname=fish 3pkgname=fish
4pkgver=2.1.2 4pkgver=2.1.2
5pkgrel=1 5pkgrel=2
6pkgdesc="a modern interactive commandline shell" 6pkgdesc="a modern interactive commandline shell"
7url="http://www.fishshell.com/" 7url="http://www.fishshell.com/"
8arch="all" 8arch="all"
9 9license="GPL2"
10# guessed from fish/fish.cpp *gag*
11license="GPL"
12
13depends="" 10depends=""
14depends_dev="ncurses-dev" 11depends_dev="ncurses-dev"
15makedepends="$depends_dev autoconf automake libtool" 12makedepends="$depends_dev autoconf automake libtool"
16install="" 13install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
17subpackages="$pkgname-doc" 14subpackages="$pkgname-doc"
18source="http://fishshell.com/files/$pkgver/fish-$pkgver.tar.gz 15source="http://fishshell.com/files/$pkgver/fish-$pkgver.tar.gz
19 fish-safe-strerror.patch" 16 fish-safe-strerror.patch"
20 17
21_builddir="$srcdir"/fish-$pkgver 18_builddir="$srcdir"/fish-$pkgver
22prepare() { 19prepare() {
23 local i
24 cd "$_builddir" 20 cd "$_builddir"
21
22 local i=
25 for i in $source; do 23 for i in $source; do
26 case $i in 24 case $i in
27 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;; 25 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1 ;;
28 esac 26 esac
29 done 27 done
30 28
@@ -33,7 +31,6 @@ prepare() {
33 31
34build() { 32build() {
35 cd "$_builddir" 33 cd "$_builddir"
36
37 ./configure --prefix=/usr \ 34 ./configure --prefix=/usr \
38 --sysconfdir=/etc || return 1 35 --sysconfdir=/etc || return 1
39 make || return 1 36 make || return 1
diff --git a/main/fish/fish.post-install b/main/fish/fish.post-install
new file mode 100644
index 0000000000..e725135f28
--- /dev/null
+++ b/main/fish/fish.post-install
@@ -0,0 +1,3 @@
1#!/bin/sh
2add-shell '/usr/bin/fish'
3exit 0
diff --git a/main/fish/fish.post-upgrade b/main/fish/fish.post-upgrade
new file mode 120000
index 0000000000..7fa98c8050
--- /dev/null
+++ b/main/fish/fish.post-upgrade
@@ -0,0 +1 @@
fish.post-install \ No newline at end of file
diff --git a/main/fish/fish.pre-deinstall b/main/fish/fish.pre-deinstall
new file mode 100644
index 0000000000..57411237fc
--- /dev/null
+++ b/main/fish/fish.pre-deinstall
@@ -0,0 +1,3 @@
1#!/bin/sh
2remove-shell '/usr/bin/fish'
3exit 0