aboutsummaryrefslogtreecommitdiff
path: root/testing/belle-sip
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-07-03 06:40:34 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-07-03 06:40:39 +0000
commit15e2f6094ec5928728d148933499132fc0220b8a (patch)
treedd1485302c4ad38c7aae5899d9032aab2a426f9b /testing/belle-sip
parent5b5d60eca80bc09801f97eeb0caf412f410fea6f (diff)
downloadalpine_aports-15e2f6094ec5928728d148933499132fc0220b8a.tar.bz2
alpine_aports-15e2f6094ec5928728d148933499132fc0220b8a.tar.xz
alpine_aports-15e2f6094ec5928728d148933499132fc0220b8a.zip
testing/belle-sip: new aport
Diffstat (limited to 'testing/belle-sip')
-rw-r--r--testing/belle-sip/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/belle-sip/APKBUILD b/testing/belle-sip/APKBUILD
new file mode 100644
index 0000000000..96d59e5be4
--- /dev/null
+++ b/testing/belle-sip/APKBUILD
@@ -0,0 +1,44 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname="belle-sip"
4pkgver="1.6.3"
5_pkgver=${pkgver}-0
6pkgrel=0
7pkgdesc="SIP (RFC3261) implementation written in C"
8url="https://www.linphone.org"
9arch="all"
10license="GPL-2.0-or-later"
11options="!check" # no test available
12makedepends="cmake libantlr3c libantlr3c-dev bctoolbox-dev
13zlib-dev mbedtls-dev openjdk10-jre-headless"
14subpackages="$pkgname-dev"
15source="https://www.linphone.org/releases/sources/${pkgname}/${pkgname}-${pkgver}.tar.gz
16antlr.jar::https://github.com/antlr/website-antlr3/blob/gh-pages/download/antlr-3.4-complete.jar?raw=true"
17builddir="$srcdir/$pkgname-$_pkgver"
18
19build() {
20 cmake \
21 -DCMAKE_INSTALL_PREFIX=/usr \
22 -DCMAKE_INSTALL_LIBDIR=lib \
23 -DCMAKE_MODULE_PATH=/usr/lib/cmake \
24 -DCMAKE_SKIP_INSTALL_RPATH=ON \
25 -DENABLE_STATIC=NO \
26 -DENABLE_SHARED=YES \
27 -DENABLE_TESTS=YES \
28 -DENABLE_STRICT=NO \
29 -DANTLR3_JAR_PATH="$srcdir"/antlr.jar .
30 make
31}
32
33package() {
34 make DESTDIR="$pkgdir" install
35}
36
37dev() {
38 default_dev
39 mkdir -p "$subpkgdir"/usr/lib/cmake/BelleSIP
40 mv "$pkgdir"/usr/share/BelleSIP/cmake/* "$subpkgdir"/usr/lib/cmake/BelleSIP
41}
42
43sha512sums="4f7049a06195a702a424fbec1671dc5075c3fbcd3fbb9dd990c15115d291ffcbde2b47440c479ef45d0f3251fa75774729c6a11ff1826adb53359c61e80c5df2 belle-sip-1.6.3.tar.gz
4404be4dfba3a21f3ab9d9e439a64958bd8e844a9f151b798383bd9e0dd6ebc416783ae7cb1d1dbb27fb7288ab9756b13b8338cdb8ceb41a10949c852ad45ab1f2 antlr.jar"