aboutsummaryrefslogtreecommitdiff
path: root/testing/breezy
diff options
context:
space:
mode:
authorPedro Filipe <pedrofilipecerqueira@outlook.com>2020-07-21 12:21:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-07-22 11:58:38 -0300
commit3053c227236d540c3ef473a3142cb0096baa85bc (patch)
tree5a553693016e4de09caccf1602ed4a75101fd64c /testing/breezy
parentf964279b0c533e847e28f81fff9db5490d6df959 (diff)
downloadalpine_aports-3053c227236d540c3ef473a3142cb0096baa85bc.tar.bz2
alpine_aports-3053c227236d540c3ef473a3142cb0096baa85bc.tar.xz
alpine_aports-3053c227236d540c3ef473a3142cb0096baa85bc.zip
testing/breezy: new aport
Decentralized revision control system https://www.breezy-vcs.org/ Co-authored-by: Leo <thinkabit.ukim@gmail.com>
Diffstat (limited to 'testing/breezy')
-rw-r--r--testing/breezy/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/breezy/APKBUILD b/testing/breezy/APKBUILD
new file mode 100644
index 0000000000..4b99d1a6aa
--- /dev/null
+++ b/testing/breezy/APKBUILD
@@ -0,0 +1,34 @@
1# Maintainer: Pedro Filipe <xpecex@outlook.com>
2pkgname=breezy
3pkgver=3.1.0
4pkgrel=0
5pkgdesc="Decentralized revision control system"
6url="https://www.breezy-vcs.org/"
7arch="all"
8license="GPL-2.0-or-later"
9depends="py3-configobj py3-six"
10makedepends="python3-dev py3-dulwich py3-fastimport py3-gpgme py3-paramiko
11 py3-setuptools gettext"
12subpackages="$pkgname-doc"
13options="!check" # Suit test not work
14source="https://launchpad.net/brz/${pkgver%.*}/$pkgver/+download/breezy-$pkgver.tar.gz"
15
16build() {
17 python3 setup.py build
18}
19
20package() {
21 python3 setup.py install --root="$pkgdir"
22 ln -s brz "$pkgdir"/usr/bin/bzr # backwards compatibility
23
24 find "$pkgdir"/usr/lib/python3*/site-packages -type d -name tests \
25 -exec rm -rf {} +
26}
27
28doc() {
29 mkdir -p "$subpkgdir"/usr/share
30 mv "$pkgdir"/usr/man "$subpkgdir"/usr/share
31 default_doc
32}
33
34sha512sums="40ea1ae364940ac8ff83d3f5da2437cc62fbda0ca98b3ae90a38dfad87555c3993b852ce186323454d7ab002ba4fbb3270e70953504e449c445efe147847204d breezy-3.1.0.tar.gz"