aboutsummaryrefslogtreecommitdiff
path: root/testing/fatresize
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-29 00:06:56 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-29 00:06:56 +0100
commitc10f2d9b183c51fddfcb61024d01a5bd21197694 (patch)
treebe05642071d1d25f7bd6a17684a76bd9bdfde63c /testing/fatresize
parent47d62840a0a17ab1d9abf62acd4542370fe5b7ad (diff)
downloadalpine_aports-c10f2d9b183c51fddfcb61024d01a5bd21197694.tar.bz2
alpine_aports-c10f2d9b183c51fddfcb61024d01a5bd21197694.tar.xz
alpine_aports-c10f2d9b183c51fddfcb61024d01a5bd21197694.zip
Remove stale patches from testing
Diffstat (limited to 'testing/fatresize')
-rw-r--r--testing/fatresize/fatresize-1.0.2-libparted_ver_check.patch14
-rw-r--r--testing/fatresize/fatresize-1.0.2-ped_assert.patch21
-rw-r--r--testing/fatresize/fatresize-1.0.2-ped_free.patch29
3 files changed, 0 insertions, 64 deletions
diff --git a/testing/fatresize/fatresize-1.0.2-libparted_ver_check.patch b/testing/fatresize/fatresize-1.0.2-libparted_ver_check.patch
deleted file mode 100644
index 333d774831..0000000000
--- a/testing/fatresize/fatresize-1.0.2-libparted_ver_check.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1diff -up fatresize-1.0.2/configure.ac.orig fatresize-1.0.2/configure.ac
2--- fatresize-1.0.2/configure.ac.orig 2005-09-20 10:30:35.000000000 +0200
3+++ fatresize-1.0.2/configure.ac 2012-12-17 23:33:06.238862845 +0100
4@@ -29,8 +29,8 @@ CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=${ac
5 dnl libparted
6 # hack
7 LIBS="$LIBS -ldl"
8-PARTED_CHECK_LIBPARTED(1.6.0, ,
9- [AC_MSG_ERROR([*** libparted >= 1.6.0 not installed - please install first ***])])
10+AC_CHECK_LIB(parted, ped_malloc, [], AC_MSG_ERROR([*** libparted >= 3.1.0 not installed - please install first ***]))
11+AC_CHECK_LIB(parted-fs-resize, ped_file_system_open, [], AC_MSG_ERROR([*** libparted-fs-resize >= 3.1.0 not installed - please install first ***]))
12
13 AC_SUBST(PARTED_LIBS)
14
diff --git a/testing/fatresize/fatresize-1.0.2-ped_assert.patch b/testing/fatresize/fatresize-1.0.2-ped_assert.patch
deleted file mode 100644
index 34877fc844..0000000000
--- a/testing/fatresize/fatresize-1.0.2-ped_assert.patch
+++ /dev/null
@@ -1,21 +0,0 @@
1diff -up fatresize-1.0.2/fatresize.c.orig fatresize-1.0.2/fatresize.c
2--- fatresize-1.0.2/fatresize.c.orig 2005-09-20 10:29:08.000000000 +0200
3+++ fatresize-1.0.2/fatresize.c 2012-12-18 00:07:00.000000000 +0100
4@@ -217,7 +217,7 @@ fatresize_handler(PedException *ex)
5 static int
6 snap(PedSector* sector, PedSector new_sector, PedGeometry* range)
7 {
8- PED_ASSERT(ped_geometry_test_sector_inside (range, *sector), return 0);
9+ PED_ASSERT(ped_geometry_test_sector_inside (range, *sector));
10 if (!ped_geometry_test_sector_inside(range, new_sector))
11 return 0;
12
13@@ -281,7 +281,7 @@ snap_to_boundaries (PedGeometry* new_geo
14 end_part->geom.end, end_part->geom.start - 1, -1);
15 }
16
17- PED_ASSERT (start <= end, return);
18+ PED_ASSERT (start <= end);
19 ped_geometry_set (new_geom, start, end - start + 1);
20 }
21
diff --git a/testing/fatresize/fatresize-1.0.2-ped_free.patch b/testing/fatresize/fatresize-1.0.2-ped_free.patch
deleted file mode 100644
index 77f4be4a82..0000000000
--- a/testing/fatresize/fatresize-1.0.2-ped_free.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1diff -up fatresize-1.0.2/fatresize.c.orig fatresize-1.0.2/fatresize.c
2--- fatresize-1.0.2/fatresize.c.orig 2005-09-20 10:29:08.000000000 +0200
3+++ fatresize-1.0.2/fatresize.c 2012-12-18 00:19:45.061745003 +0100
4
5@@ -320,11 +320,11 @@ partition_warn_busy(PedPartition* part)
6 ("Partition %s is being used. You must unmount it "
7 "before you modify it with Parted."),
8 path);
9- ped_free(path);
10+ free(path);
11 return 0;
12 }
13
14- ped_free(path);
15+ free(path);
16 return 1;
17 }
18
19@@ -507,8 +507,8 @@ main(int argc, char **argv)
20 }
21 else if (!ped_unit_parse(def_str, dev, &end, &range_end))
22 return 1;
23- ped_free(old_str);
24- ped_free(def_str);
25+ free(old_str);
26+ free(def_str);
27
28 printd(3, "ped_geometry_duplicate()\n");
29 old_geom = ped_geometry_duplicate(&part->geom);