aboutsummaryrefslogtreecommitdiff
path: root/testing/k9s
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-09-09 00:15:39 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-09-08 23:41:30 +0000
commitfa9e1df6f17d47c67687e285e6729c12b77e2788 (patch)
treea2ec64efae4f884471fbc16e82bbf9fa62fd6b13 /testing/k9s
parent75ff6ac53d88c39486e33ec1e0f1d48bbb195ff2 (diff)
downloadalpine_aports-fa9e1df6f17d47c67687e285e6729c12b77e2788.tar.bz2
alpine_aports-fa9e1df6f17d47c67687e285e6729c12b77e2788.tar.xz
alpine_aports-fa9e1df6f17d47c67687e285e6729c12b77e2788.zip
testing/k9s: upgrade to 0.21.7
Diffstat (limited to 'testing/k9s')
-rw-r--r--testing/k9s/01-fix_action.patch24
-rw-r--r--testing/k9s/APKBUILD14
2 files changed, 33 insertions, 5 deletions
diff --git a/testing/k9s/01-fix_action.patch b/testing/k9s/01-fix_action.patch
new file mode 100644
index 0000000000..5353f2489c
--- /dev/null
+++ b/testing/k9s/01-fix_action.patch
@@ -0,0 +1,24 @@
1# Fix build failure until it is upstreamed: https://github.com/derailed/k9s/issues/865
2
3From 43351ae8a51042aaf8ee987c4722178bdf4c5f9b Mon Sep 17 00:00:00 2001
4From: =?UTF-8?q?Trung=20L=C3=AA?= <trung.le@ruby-journal.com>
5Date: Tue, 8 Sep 2020 00:24:19 +1000
6Subject: [PATCH 1/2] Convert int to string using rune()
7
8---
9 internal/ui/action.go | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/internal/ui/action.go b/internal/ui/action.go
13index a98da5ef..072f5802 100644
14--- a/internal/ui/action.go
15+++ b/internal/ui/action.go
16@@ -83,7 +83,7 @@ func (a KeyActions) Hints() model.MenuHints {
17 },
18 )
19 } else {
20- log.Error().Msgf("Unable to locate KeyName for %#v", string(k))
21+ log.Error().Msgf("Unable to locate KeyName for %#v", string(rune(k)))
22 }
23 }
24 return hh
diff --git a/testing/k9s/APKBUILD b/testing/k9s/APKBUILD
index 61ee59e6f4..6196d55e99 100644
--- a/testing/k9s/APKBUILD
+++ b/testing/k9s/APKBUILD
@@ -2,17 +2,20 @@
2# Maintainer: Galen Abell <galen@galenabell.com> 2# Maintainer: Galen Abell <galen@galenabell.com>
3pkgname=k9s 3pkgname=k9s
4_pkgname=github.com/derailed/k9s 4_pkgname=github.com/derailed/k9s
5pkgver=0.20.2 5pkgver=0.21.7
6pkgrel=0 6pkgrel=0
7_commit=218388c # git rev-parse --short HEAD 7_commit=cc0e8e8 # git rev-parse --short HEAD
8_date=2020-06-02T15:50:42UTC # date -u -d @$(date +%s) +%FT%T%Z 8_date=2020-09-06T17:07:54UTC # date -u -d @$(date +%s) +%FT%T%Z
9pkgdesc="Kubernetes TUI" 9pkgdesc="Kubernetes TUI"
10url="https://k9scli.io" 10url="https://k9scli.io"
11arch="all !x86 !mips64" # tests fail on x86 for some reason, missing go on mips 11arch="all !x86 !mips64" # tests fail on x86 for some reason, missing go on mips
12license="Apache-2.0" 12license="Apache-2.0"
13makedepends="go" 13makedepends="go"
14options="net chmod-clean" 14options="net chmod-clean"
15source="$pkgname-$pkgver.tar.gz::https://github.com/derailed/k9s/archive/v$pkgver.tar.gz" 15source="
16 $pkgname-$pkgver.tar.gz::https://github.com/derailed/k9s/archive/v$pkgver.tar.gz
17 01-fix_action.patch
18 "
16 19
17export GOPATH="$srcdir/go" 20export GOPATH="$srcdir/go"
18export GOCACHE="$srcdir/go-build" 21export GOCACHE="$srcdir/go-build"
@@ -31,4 +34,5 @@ package() {
31 install -Dm755 execs/$pkgname "$pkgdir"/usr/bin/$pkgname 34 install -Dm755 execs/$pkgname "$pkgdir"/usr/bin/$pkgname
32} 35}
33 36
34sha512sums="4ba2dd5fbc7da084e33cd4688b6689395a13a2192867597dccf1057cb052598d03d87d03cd08d02e0c25f5cdaec786add2b0c019d8fbc0fd67841b3ae0993025 k9s-0.20.2.tar.gz" 37sha512sums="ea1ce0c84013ec9d46e98b9fa53be1e889aab3630dbd34c06f0d0ff45c30e89b5657182a0490a5832f2a91e17a1401c42bf3edc7f679c53acfcc494fbe1bf141 k9s-0.21.7.tar.gz
389c2e637336aaf88dfc9202ae89b14979d6cb99c0a4c9945e4ba75077dc99d3534b2c8cf0f6d4d818fc29c476ab3c6253e873c11ce3aa1db11777a698cd4a8a6a 01-fix_action.patch"