aboutsummaryrefslogtreecommitdiff
path: root/testing/libcorkipset
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-06 15:43:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 06:04:37 -0300
commit847c033cf9b1fc68cae11473b471ea3cac865675 (patch)
treed40e2bb22c87b6da73a842b87b07eaf31da24ccd /testing/libcorkipset
parent9feb870df03b03a11cdb85fad08482e998e3be7a (diff)
downloadalpine_aports-847c033cf9b1fc68cae11473b471ea3cac865675.tar.bz2
alpine_aports-847c033cf9b1fc68cae11473b471ea3cac865675.tar.xz
alpine_aports-847c033cf9b1fc68cae11473b471ea3cac865675.zip
testing/libcorkipset: new aport
Small C helper library for storing sets of IPv4 and IPv6 addresses https://github.com/rogers0/libcorkipset
Diffstat (limited to 'testing/libcorkipset')
-rw-r--r--testing/libcorkipset/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/libcorkipset/APKBUILD b/testing/libcorkipset/APKBUILD
new file mode 100644
index 0000000000..bc239666d5
--- /dev/null
+++ b/testing/libcorkipset/APKBUILD
@@ -0,0 +1,53 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
2# Maintainer: Leo <thinkabit.ukim@gmail.com>
3pkgname=libcorkipset
4pkgver=1.1.1
5_debver=20150311-8
6pkgrel=0
7pkgdesc="Small C helper library for storing sets of IPv4 and IPv6 addresses"
8url="https://github.com/rogers0/libcorkipset"
9arch="all"
10license="BSD-3-Clause"
11makedepends="cmake check-dev libcork-dev"
12checkdepends="python3"
13subpackages="$pkgname-dev"
14source="
15 $pkgname-$pkgver.tar.gz::https://github.com/rogers0/$pkgname/archive/debian/$pkgver+$_debver.tar.gz
16 "
17
18builddir="$srcdir/$pkgname-debian-$pkgver-$_debver"
19
20prepare() {
21 default_prepare
22 mkdir build
23
24 for p in debian/patches/*.patch; do
25 patch -p1 -i "$p"
26 done
27
28 sed -e 's%#include <ipset%#include <libcorkipset%' \
29 -e 's%#include "ipset%#include "libcorkipset%' \
30 -i include/ipset/*.h */*/*/*.c */*/*/*.c.in */*/*.c */*.c
31 mv include/ipset include/libcorkipset
32}
33
34build() {
35 cd build
36 cmake .. \
37 -DCMAKE_INSTALL_PREFIX=/usr \
38 -DCMAKE_INSTALL_LIBDIR=lib \
39 -DCMAKE_BUILD_STYLE=Release
40 make
41}
42
43check() {
44 cd build
45 make test
46}
47
48package() {
49 cd build
50 make DESTDIR="$pkgdir" install
51}
52
53sha512sums="5bbce2727da1665e734981959ecb253b4052d8cc6c426fded7e1678b6e2505bc9f4c0ab3cd3b6a03f834f5e20bd1d670cc19f7491fe0ad5b7cb772e7309f5009 libcorkipset-1.1.1.tar.gz"