aboutsummaryrefslogtreecommitdiff
path: root/testing/libgpod
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-09-29 06:09:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-09-29 06:10:11 -0300
commit2f7ed3513b687316e9ef458e7f1fc29cb8432268 (patch)
tree4aadd4284f0ed4833f273c93f6539c87119083ef /testing/libgpod
parentd827cb3f6c77a91a5025db575a7885039662a789 (diff)
downloadalpine_aports-2f7ed3513b687316e9ef458e7f1fc29cb8432268.tar.bz2
alpine_aports-2f7ed3513b687316e9ef458e7f1fc29cb8432268.tar.xz
alpine_aports-2f7ed3513b687316e9ef458e7f1fc29cb8432268.zip
testing/libgpod: rebuild against libplist-2.0
Diffstat (limited to 'testing/libgpod')
-rw-r--r--testing/libgpod/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/testing/libgpod/APKBUILD b/testing/libgpod/APKBUILD
index f780098849..66be5c4ed1 100644
--- a/testing/libgpod/APKBUILD
+++ b/testing/libgpod/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org> 2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname=libgpod 3pkgname=libgpod
4pkgver=0.8.3 4pkgver=0.8.3
5pkgrel=3 5pkgrel=4
6pkgdesc="A shared library to access the contents of an iPod" 6pkgdesc="A shared library to access the contents of an iPod"
7url="http://www.gtkpod.org/libgpod" 7url="http://www.gtkpod.org/libgpod"
8arch="all" 8arch="all"
@@ -15,12 +15,15 @@ source="https://downloads.sourceforge.net/project/gtkpod/libgpod/libgpod-0.8/lib
15 0001-323-Segmentation-fault-when-opening-ipod.patch 15 0001-323-Segmentation-fault-when-opening-ipod.patch
16 0002-Fix-spelling-errors-in-comments-and-strings-using-co.patch 16 0002-Fix-spelling-errors-in-comments-and-strings-using-co.patch
17 0003-Fixed-PList-deprecation.patch 17 0003-Fixed-PList-deprecation.patch
18 libgpod-0.8.2-pkgconfig_overlinking.patch" 18 libgpod-0.8.2-pkgconfig_overlinking.patch
19 "
19 20
20replaces="py-libgpod" # Removed in 0.8.3-r2 21replaces="py-libgpod" # Removed in 0.8.3-r2
21 22
22check() { 23prepare() {
23 make check 24 default_prepare
25 sed -e 's|libplist >= 1.0|libplist-2.0 >= 2.2|' -i configure.ac # support libplist 2.2
26 autoreconf -fi
24} 27}
25 28
26build() { 29build() {
@@ -32,6 +35,10 @@ build() {
32 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool 35 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
33} 36}
34 37
38check() {
39 make check
40}
41
35package() { 42package() {
36 make PREFIX=/usr DESTDIR="$pkgdir" install 43 make PREFIX=/usr DESTDIR="$pkgdir" install
37} 44}