aboutsummaryrefslogtreecommitdiff
path: root/testing/libnpupnp
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-08-14 03:45:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-08-14 07:10:40 +0000
commitd7e1b944f5353da4f4d73c37c6928552191cb774 (patch)
tree280a05c39457551f664f66994a2a860833e12958 /testing/libnpupnp
parent143efb1478a3fa761da87f6ac985b95ed42480dc (diff)
downloadalpine_aports-d7e1b944f5353da4f4d73c37c6928552191cb774.tar.bz2
alpine_aports-d7e1b944f5353da4f4d73c37c6928552191cb774.tar.xz
alpine_aports-d7e1b944f5353da4f4d73c37c6928552191cb774.zip
testing/libnpupnp: new aport
https://www.lesbonscomptes.com/upmpdcli/libnpupnp.html UPnP library based on libupnp, but extensively rewritten
Diffstat (limited to 'testing/libnpupnp')
-rw-r--r--testing/libnpupnp/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libnpupnp/APKBUILD b/testing/libnpupnp/APKBUILD
new file mode 100644
index 0000000000..67a8f72e22
--- /dev/null
+++ b/testing/libnpupnp/APKBUILD
@@ -0,0 +1,33 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
2# Maintainer: Leo <thinkabit.ukim@gmail.com>
3pkgname=libnpupnp
4pkgver=4.0.10
5pkgrel=0
6pkgdesc="UPnP library based on libupnp, but extensively rewritten"
7url="https://www.lesbonscomptes.com/upmpdcli/libnpupnp.html"
8arch="all"
9license="BSD-3-Clause"
10makedepends="expat-dev curl-dev libmicrohttpd-dev"
11subpackages="$pkgname-dev"
12source="https://www.lesbonscomptes.com/upmpdcli/downloads/libnpupnp-$pkgver.tar.gz"
13
14build() {
15 ./configure \
16 --build=$CBUILD \
17 --host=$CHOST \
18 --prefix=/usr \
19 --sysconfdir=/etc \
20 --mandir=/usr/share/man \
21 --localstatedir=/var
22 make
23}
24
25check() {
26 make check
27}
28
29package() {
30 make DESTDIR="$pkgdir" install
31}
32
33sha512sums="d5259a1841d5afbca9781532211f4bde3a3987759adfa3fb071d0c59fe10c7d38fccab9aea36636085fbe53622c80ee058ec50612aacd36cae8178e946648021 libnpupnp-4.0.10.tar.gz"