aboutsummaryrefslogtreecommitdiff
path: root/testing/libzim
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-03-21 16:22:57 -0600
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-22 20:04:38 +0000
commitbb4c79c6a82791e5823084cbeffcc157ae55c938 (patch)
treedd1964c5649ac8da6ff9eee897050ce1f7962775 /testing/libzim
parentc88cf8a1149cc83d91f3ff6e694f35c6093a6411 (diff)
downloadalpine_aports-bb4c79c6a82791e5823084cbeffcc157ae55c938.tar.bz2
alpine_aports-bb4c79c6a82791e5823084cbeffcc157ae55c938.tar.xz
alpine_aports-bb4c79c6a82791e5823084cbeffcc157ae55c938.zip
testing/libzim: new aport
https://openzim.org/ Reference implementation of the ZIM file format
Diffstat (limited to 'testing/libzim')
-rw-r--r--testing/libzim/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/libzim/APKBUILD b/testing/libzim/APKBUILD
new file mode 100644
index 0000000000..140132c4b9
--- /dev/null
+++ b/testing/libzim/APKBUILD
@@ -0,0 +1,40 @@
1# Contributor: Oleg Titov <oleg.titov@gmail.com>
2# Maintainer: Oleg Titov <oleg.titov@gmail.com>
3pkgname=libzim
4pkgver=4.0.6
5pkgrel=0
6pkgdesc="Reference implementation of the ZIM file format"
7url="https://openzim.org/"
8arch="all"
9license="GPL-2.0"
10makedepends="meson zlib-dev xz-dev libexecinfo libexecinfo-dev icu-dev xapian-core-dev
11gtest gtest-dev python3-dev"
12subpackages="$pkgname-dev $pkgname-doc"
13source="$pkgname-$pkgver.tar.gz::https://github.com/openzim/$pkgname/archive/$pkgver.tar.gz"
14builddir="$srcdir/$pkgname-$pkgver"
15
16build() {
17 cd "$builddir"
18 LDFLAGS=-lexecinfo meson \
19 --prefix=/usr \
20 --sysconfdir=/etc \
21 --mandir=/usr/share/man \
22 --localstatedir=/var \
23 --buildtype=release \
24 . output
25 ninja -C output
26}
27
28check() {
29 ninja -C output test
30}
31
32package() {
33 cd "$builddir"
34 DESTDIR="$pkgdir" ninja -C output install
35
36 install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING
37 install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
38}
39
40sha512sums="163777ec1e3935b1e71cc30c72a5645c8519592ad30aa544b08fbdfc0f5c50a7d4199d9038028209fa9accc0e2264008aa8931c49e831273ce2b9a6c4062ad37 libzim-4.0.6.tar.gz"