aboutsummaryrefslogtreecommitdiff
path: root/testing/lrdf
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-17 16:04:30 +0200
committerTBK <tbk@jjtc.eu>2020-04-19 09:51:06 +0000
commit71a9d0734c9d7c7c0116272c05d2aaaa5102357e (patch)
tree03ff8c84a3aad412ab3c6917d4a8b03019047ed4 /testing/lrdf
parentfb9980915264bfe55da0616f31541dd3edd35ce0 (diff)
downloadalpine_aports-71a9d0734c9d7c7c0116272c05d2aaaa5102357e.tar.bz2
alpine_aports-71a9d0734c9d7c7c0116272c05d2aaaa5102357e.tar.xz
alpine_aports-71a9d0734c9d7c7c0116272c05d2aaaa5102357e.zip
testing/lrdf: new aport
https://github.com/swh/LRDF RDF library for accessing plugin metadata in the LADSPA plugin system
Diffstat (limited to 'testing/lrdf')
-rw-r--r--testing/lrdf/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/lrdf/APKBUILD b/testing/lrdf/APKBUILD
new file mode 100644
index 0000000000..0581af5ea4
--- /dev/null
+++ b/testing/lrdf/APKBUILD
@@ -0,0 +1,36 @@
1# Contributor: David Demelier <markand@malikania.fr>
2# Maintainer: David Demelier <markand@malikania.fr>
3pkgname=lrdf
4pkgver=0.6.1
5pkgrel=0
6pkgdesc="RDF library for accessing plugin metadata in the LADSPA plugin system"
7url="https://github.com/swh/LRDF"
8arch="all"
9license="GPL-2.0-only"
10makedepends="autoconf automake libtool raptor2-dev"
11subpackages="$pkgname-static $pkgname-dev"
12source="$pkgname-$pkgver.tar.gz::https://github.com/swh/LRDF/archive/v0.6.1.tar.gz"
13builddir="$srcdir/LRDF-$pkgver"
14options="!check" # remove_test not working: https://github.com/swh/LRDF/issues/15
15
16prepare() {
17 default_prepare
18 autoreconf -vif
19}
20
21build() {
22 ./configure \
23 --build=$CBUILD \
24 --host=$CHOST \
25 --prefix=/usr \
26 --sysconfdir=/etc \
27 --mandir=/usr/share/man \
28 --localstatedir=/var
29 make
30}
31
32package() {
33 make DESTDIR="$pkgdir" install
34}
35
36sha512sums="7732813eec704aef984d056de254e4fa049fdd0a7444b6a88f75f012afe9c587cbd1295f027c77361fa42bc097cdce9d9cabdba6b86e99a3c14805d84258df1c lrdf-0.6.1.tar.gz"