aboutsummaryrefslogtreecommitdiff
path: root/testing/mediastreamer2
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-07-03 08:23:26 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-07-03 08:23:26 +0000
commit6e778523d40a1fbace7883193d124d36abe98a51 (patch)
treec2562892aa5155b58c90ca1f0530569362eae077 /testing/mediastreamer2
parent8597a6fb66d795ded8a994d0521eb31d9cf8f702 (diff)
downloadalpine_aports-6e778523d40a1fbace7883193d124d36abe98a51.tar.bz2
alpine_aports-6e778523d40a1fbace7883193d124d36abe98a51.tar.xz
alpine_aports-6e778523d40a1fbace7883193d124d36abe98a51.zip
testing/mediastreamer2: new aport
Diffstat (limited to 'testing/mediastreamer2')
-rw-r--r--testing/mediastreamer2/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/mediastreamer2/APKBUILD b/testing/mediastreamer2/APKBUILD
new file mode 100644
index 0000000000..126fcf73a3
--- /dev/null
+++ b/testing/mediastreamer2/APKBUILD
@@ -0,0 +1,54 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname="mediastreamer2"
4_pkgname=${pkgname/2/}
5pkgver="2.16.1"
6pkgrel=0
7pkgdesc="A library written in C that allows you to create and run audio and video streams"
8url="https://www.linphone.org/technical-corner/mediastreamer2/overview"
9arch="all"
10license="GPL-2.0-or-later"
11options="!check" # no test available
12makedepends="cmake gettext-dev ffmpeg-dev ortp-dev
13 libxv-dev speex-dev speexdsp-dev libsrtp-dev
14 v4l-utils-dev bctoolbox-dev mesa-dev glew-dev
15 opus-dev libpcap-dev spandsp-dev tiff-dev libtheora-dev
16 alsa-lib-dev python3-dev gsm-dev
17 libpcap-dev jpeg-dev"
18subpackages="$pkgname-dev"
19source="https://www.linphone.org/releases/sources/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
20builddir="$srcdir/$_pkgname-$pkgver"
21
22build() {
23 cmake \
24 -DCMAKE_INSTALL_PREFIX=/usr \
25 -DCMAKE_INSTALL_LIBDIR=lib \
26 -DCMAKE_MODULE_PATH=/usr/lib/cmake \
27 -DCMAKE_SKIP_INSTALL_RPATH=ON \
28 -DENABLE_STRICT=NO \
29 -DENABLE_ALSA=YES \
30 -DENABLE_STATIC=NO \
31 -DENABLE_RESAMPLE=YES \
32 -DENABLE_JPEG=YES \
33 -DENABLE_PCAP=YES \
34 -DENABLE_FFMPEG=YES \
35 -DENABLE_SPEEX_CODEC=YES \
36 -DENABLE_SPEEX_DSP=YES \
37 -DENABLE_SHARED=YES .
38 make
39}
40
41package() {
42 make DESTDIR="$pkgdir" install
43}
44
45dev() {
46 default_dev
47 mkdir -p "$subpkgdir"/usr/lib/cmake/Mediastreamer2
48 mv "$pkgdir"/usr/share/Mediastreamer2/cmake/* "$subpkgdir"/usr/lib/cmake/Mediastreamer2
49 # Remove empty dirs
50 rmdir "$pkgdir"/usr/share/Mediastreamer2/cmake
51 rmdir "$pkgdir"/usr/share/Mediastreamer2
52}
53
54sha512sums="44b3a5092aedf65b5503c7843c88e4acc2d0e72093a4f057440355c281135a17c898c1c01438e372bf7c8ae2f30a79ad8a59315f3f3d9b914599a185e90fbe81 mediastreamer-2.16.1.tar.gz"