aboutsummaryrefslogtreecommitdiff
path: root/testing/nut
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-06-13 17:29:29 +0300
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-07 11:38:04 +0200
commite409857fde32cd84d3f9de1c169336ee0d071e92 (patch)
treeb8920ba6373b1a4b909d43d1236f131acf4f1c7c /testing/nut
parentf1ec1ed9cc65d443bd48756b40eff58466c87b80 (diff)
downloadalpine_aports-e409857fde32cd84d3f9de1c169336ee0d071e92.tar.bz2
alpine_aports-e409857fde32cd84d3f9de1c169336ee0d071e92.tar.xz
alpine_aports-e409857fde32cd84d3f9de1c169336ee0d071e92.zip
testing/nut: Upgrade to 2.7.4. conf.d & init.d cleanups
- rename all /etc/nut/*.conf.sample to /etc/nut/*.conf - make conf.d/* init.d/* more clean and openrc-run'ed - nut-upsmon now dynamically depends on nut-upsd if the MODE parameter in /etc/nut/nut.conf is set to 'standalone' or 'netserver'. - make a user and group creation in pre-install. I think we need to remove this user/group from alpine-baselayout.
Diffstat (limited to 'testing/nut')
-rw-r--r--testing/nut/APKBUILD81
-rw-r--r--testing/nut/config-sub.patch313
-rw-r--r--testing/nut/nut-upsd.confd3
-rw-r--r--testing/nut/nut-upsd.initd53
-rw-r--r--testing/nut/nut-upsmon.confd3
-rw-r--r--testing/nut/nut-upsmon.initd43
-rw-r--r--testing/nut/nut.confd2
-rw-r--r--testing/nut/nut.pre-install5
-rw-r--r--testing/nut/upsd.initd39
-rw-r--r--testing/nut/upsmon.initd34
10 files changed, 114 insertions, 462 deletions
diff --git a/testing/nut/APKBUILD b/testing/nut/APKBUILD
index 45c94d27ab..bf9efaf21d 100644
--- a/testing/nut/APKBUILD
+++ b/testing/nut/APKBUILD
@@ -1,8 +1,9 @@
1# Contributor: Valery Kartel <valery.kartel@gmail.com>
1# Contributor: Kozak Ivan <kozak-iv@yandex.ru> 2# Contributor: Kozak Ivan <kozak-iv@yandex.ru>
2# Maintainer: Kozak Ivan <kozak-iv@yandex.ru> 3# Maintainer: Kozak Ivan <kozak-iv@yandex.ru>
3pkgname=nut 4pkgname=nut
4pkgver=2.7.3 5pkgver=2.7.4
5pkgrel=1 6pkgrel=0
6pkgdesc="Network UPS tools - server" 7pkgdesc="Network UPS tools - server"
7url="http://www.networkupstools.org" 8url="http://www.networkupstools.org"
8arch="all" 9arch="all"
@@ -14,32 +15,19 @@ pkggroups="nut"
14install="$pkgname.pre-install" 15install="$pkgname.pre-install"
15subpackages="$pkgname-doc $pkgname-dev" 16subpackages="$pkgname-doc $pkgname-dev"
16source="http://www.networkupstools.org/source/2.7/$pkgname-$pkgver.tar.gz 17source="http://www.networkupstools.org/source/2.7/$pkgname-$pkgver.tar.gz
17 nut-upsd.initd 18 nut.confd
18 nut-upsd.confd 19 upsd.initd
19 nut-upsmon.initd 20 upsmon.initd
20 nut-upsmon.confd 21 "
21 config-sub.patch" 22builddir="$srcdir"/$pkgname-$pkgver
22
23_builddir="$srcdir"/$pkgname-$pkgver
24
25prepare() {
26 local i
27 cd "$_builddir"
28 for i in $source; do
29 case $i in
30 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
31 esac
32 done
33 libtoolize --force && aclocal -I m4 && autoconf \
34 && automake --add-missing && update_config_sub
35}
36 23
37build() { 24build() {
38 cd "$_builddir" 25 cd "$builddir"
39 ./configure \ 26 ./configure \
40 --build=$CBUILD \ 27 --build=$CBUILD \
41 --host=$CHOST \ 28 --host=$CHOST \
42 --prefix=/usr \ 29 --prefix=/usr \
30 --libexecdir=/lib/nut \
43 --without-wrap \ 31 --without-wrap \
44 --with-user=nut \ 32 --with-user=nut \
45 --with-group=nut \ 33 --with-group=nut \
@@ -65,31 +53,30 @@ build() {
65} 53}
66 54
67package() { 55package() {
68 cd "$_builddir" 56 cd "$builddir"
69 make DESTDIR="$pkgdir" install || return 1 57 make DESTDIR="$pkgdir" install || return 1
70 chmod 640 "$pkgdir"/etc/nut/* || return 1 58 chmod -R 640 "$pkgdir"/etc/nut || return 1
71 chown root:nut "$pkgdir"/etc/nut/* || return 1 59 chown -R root:nut "$pkgdir"/etc/nut || return 1
72 install -D -m0755 "$srcdir"/nut-upsd.initd "$pkgdir"/etc/init.d/nut-upsd || return 1 60
73 install -D -m0644 "$srcdir"/nut-upsd.confd "$pkgdir"/etc/conf.d/nut-upsd || return 1 61 for i in "$pkgdir"/etc/nut/*.sample; do
74 install -D -m0755 "$srcdir"/nut-upsmon.initd "$pkgdir"/etc/init.d/nut-upsmon || return 1 62 mv $i ${i%.*} || return 1
75 install -D -m0644 "$srcdir"/nut-upsmon.confd "$pkgdir"/etc/conf.d/nut-upsmon || return 1 63 done
64
65 for i in upsd upsmon; do
66 install -Dm 755 "$srcdir"/$i.initd "$pkgdir"/etc/init.d/nut-$i || return 1
67 install -Dm 644 "$srcdir"/nut.confd "$pkgdir"/etc/conf.d/nut-$i || return 1
68 done
76} 69}
77 70
78md5sums="a1a7f747093663e1f39ab595b63b45e4 nut-2.7.3.tar.gz 71md5sums="3ba53656933d7471f95140b32a5b8d5c nut-2.7.4.tar.gz
792a5b693a967040270edc883e61f7ddef nut-upsd.initd 72bc62400005fdb77637d6e0002c6aaad6 nut.confd
806b068c71884f8d66b5b7395b4a14d821 nut-upsd.confd 73a95924ff4895c08e785a2c36c31d2f8e upsd.initd
8130dc9b43f956d7a6545f71a0d1d8dc47 nut-upsmon.initd 74e294774dcacce44c0d5a3abd3af21a92 upsmon.initd"
826b068c71884f8d66b5b7395b4a14d821 nut-upsmon.confd 75sha256sums="980e82918c52d364605c0703a5dcf01f74ad2ef06e3d365949e43b7d406d25a7 nut-2.7.4.tar.gz
832073c7d345cc59f6dc4f4322f63ccfa0 config-sub.patch" 763557d7db3e90f09f350f1651dbe2714ee5317735f3cccfed087462c34f1b55a2 nut.confd
84sha256sums="ff44d95d06a51559a0a018eef7f8d17911c1002b6352a7d7580ff75acb12126b nut-2.7.3.tar.gz 772a760088f3d73010ccd78277352eb3ea68ddf7e5884570624299833bc7f5d1c4 upsd.initd
852eff9796f0e8d0e82c8d4ac1220885db5e09b8b91f4f49ce590da028e210aa2a nut-upsd.initd 7860f9afbe2a69087d10b353e49460aa436d5f307eafbd83f31640a5f83881954f upsmon.initd"
868ee7ff65c3ef84bb1bc0b458ff5b574bb8a6ac656a6d3a40441185b352481dda nut-upsd.confd 79sha512sums="320c4aff85d8a370c5eff77d33924fdfc3caf6a250620693cdd5bf3336b3a80d8a207488eee841bcf8b72fbad68fda4c074e63b99c56e7886716fc934122d11a nut-2.7.4.tar.gz
8737924fe62b4c837579283f080990d2e4cbd84dd85fd5c3c0fd45f665152a7d86 nut-upsmon.initd 80de59b3ab84553780874aeb9edf5faaa1fe19144406f58d40e878cc4cf520440d95a57645a6e3fdd84fdec77c6840ab2185b9554a423f7b9b8b6bca4a1795fb78 nut.confd
888ee7ff65c3ef84bb1bc0b458ff5b574bb8a6ac656a6d3a40441185b352481dda nut-upsmon.confd 81d578a4a383d15adb8d285c49e540c2177875a80396816ac70048a3d269d841c8c56c9ddc45b8062572ee899f19061630296f4d28e00c0c72fefdee98802126f8 upsd.initd
898e44edcbfa1f2f9344659ca08bfeb93dec3e8356257b882d07aa61107fdac4a0 config-sub.patch" 8238b14cde133fe940923efdf3d6b4faf6e87c779025ee28143855d0b659c7e6916bbe509599e6310abcbd91a2a85627351eda9e332f8f48317b736d486191176c upsmon.initd"
90sha512sums="3dd978712dc0fabe7e194dbf6d7bb442c456aa4d45bfc63ede8a3acae23c66811cbcf2705b55a6739129b5f120e6f5865bcb9d19eb9080507a85e2624d5663d6 nut-2.7.3.tar.gz
9194333e58fca66111318f04f00f225a2203716b3d0bbfa39593a71de16f740df8623fdffba2e7821b3ae92e96c2fb4a0ac3661f1da31409f3b13b8f704e9c07c9 nut-upsd.initd
92cf93ce44cb6fcf980f48f77abeeabb8d0b4008e8258cf7085d68b2a9c5c10c818dbf0030630218fcf8d9c9aba43c06bda28f91efca9cc783438ec0192f10eb5d nut-upsd.confd
9331ac70d1ec5c2db7e7faf2db14ab03a012287e2b0cc3e42755e7886e444a11a701cf870d89d44d7a80f3034f9856a163269a9071dd25f2f98e416677c18b0791 nut-upsmon.initd
94cf93ce44cb6fcf980f48f77abeeabb8d0b4008e8258cf7085d68b2a9c5c10c818dbf0030630218fcf8d9c9aba43c06bda28f91efca9cc783438ec0192f10eb5d nut-upsmon.confd
959253bc4eb3ed48ef4978e4948a3febbc7fb40067b3bdf642b8fb362e7e791d3bd91da25a7941965a675eb5e5ed9ef8b434d1a50bb499722a9805d3a689077e52 config-sub.patch"
diff --git a/testing/nut/config-sub.patch b/testing/nut/config-sub.patch
deleted file mode 100644
index 22bbbad541..0000000000
--- a/testing/nut/config-sub.patch
+++ /dev/null
@@ -1,313 +0,0 @@
1diff --git a/config.sub b/config.sub
2index bba4efb..6205f84 100755
3--- a/config.sub
4+++ b/config.sub
5@@ -1,18 +1,24 @@
6 #! /bin/sh
7 # Configuration validation subroutine script.
8-# Copyright 1992-2014 Free Software Foundation, Inc.
9+# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
10+# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
11+# 2011, 2012 Free Software Foundation, Inc.
12
13-timestamp='2014-09-11'
14+timestamp='2012-04-18'
15
16-# This file is free software; you can redistribute it and/or modify it
17-# under the terms of the GNU General Public License as published by
18-# the Free Software Foundation; either version 3 of the License, or
19+# This file is (in principle) common to ALL GNU software.
20+# The presence of a machine in this file suggests that SOME GNU software
21+# can handle that machine. It does not imply ALL GNU software can.
22+#
23+# This file is free software; you can redistribute it and/or modify
24+# it under the terms of the GNU General Public License as published by
25+# the Free Software Foundation; either version 2 of the License, or
26 # (at your option) any later version.
27 #
28-# This program is distributed in the hope that it will be useful, but
29-# WITHOUT ANY WARRANTY; without even the implied warranty of
30-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
31-# General Public License for more details.
32+# This program is distributed in the hope that it will be useful,
33+# but WITHOUT ANY WARRANTY; without even the implied warranty of
34+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
35+# GNU General Public License for more details.
36 #
37 # You should have received a copy of the GNU General Public License
38 # along with this program; if not, see <http://www.gnu.org/licenses/>.
39@@ -20,12 +26,11 @@ timestamp='2014-09-11'
40 # As a special exception to the GNU General Public License, if you
41 # distribute this file as part of a program that contains a
42 # configuration script generated by Autoconf, you may include it under
43-# the same distribution terms that you use for the rest of that
44-# program. This Exception is an additional permission under section 7
45-# of the GNU General Public License, version 3 ("GPLv3").
46+# the same distribution terms that you use for the rest of that program.
47
48
49-# Please send patches with a ChangeLog entry to config-patches@gnu.org.
50+# Please send patches to <config-patches@gnu.org>. Submit a context
51+# diff and a properly formatted GNU ChangeLog entry.
52 #
53 # Configuration subroutine to validate and canonicalize a configuration type.
54 # Supply the specified configuration type as an argument.
55@@ -68,7 +73,9 @@ Report bugs and patches to <config-patches@gnu.org>."
56 version="\
57 GNU config.sub ($timestamp)
58
59-Copyright 1992-2014 Free Software Foundation, Inc.
60+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
61+2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
62+Free Software Foundation, Inc.
63
64 This is free software; see the source for copying conditions. There is NO
65 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
66@@ -116,7 +123,7 @@ esac
67 maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
68 case $maybe_os in
69 nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
70- linux-musl* | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
71+ linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
72 knetbsd*-gnu* | netbsd*-gnu* | \
73 kopensolaris*-gnu* | \
74 storm-chaos* | os2-emx* | rtmk-nova*)
75@@ -149,7 +156,7 @@ case $os in
76 -convergent* | -ncr* | -news | -32* | -3600* | -3100* | -hitachi* |\
77 -c[123]* | -convex* | -sun | -crds | -omron* | -dg | -ultra | -tti* | \
78 -harris | -dolphin | -highlevel | -gould | -cbm | -ns | -masscomp | \
79- -apple | -axis | -knuth | -cray | -microblaze*)
80+ -apple | -axis | -knuth | -cray | -microblaze)
81 os=
82 basic_machine=$1
83 ;;
84@@ -252,12 +259,10 @@ case $basic_machine in
85 | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
86 | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
87 | am33_2.0 \
88- | arc | arceb \
89- | arm | arm[bl]e | arme[lb] | armv[2-8] | armv[3-8][lb] | armv7[arm] \
90- | avr | avr32 \
91- | be32 | be64 \
92+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
93+ | be32 | be64 \
94 | bfin \
95- | c4x | c8051 | clipper \
96+ | c4x | clipper \
97 | d10v | d30v | dlx | dsp16xx \
98 | epiphany \
99 | fido | fr30 | frv \
100@@ -265,11 +270,10 @@ case $basic_machine in
101 | hexagon \
102 | i370 | i860 | i960 | ia64 \
103 | ip2k | iq2000 \
104- | k1om \
105 | le32 | le64 \
106 | lm32 \
107 | m32c | m32r | m32rle | m68000 | m68k | m88k \
108- | maxq | mb | microblaze | microblazeel | mcore | mep | metag \
109+ | maxq | mb | microblaze | mcore | mep | metag \
110 | mips | mipsbe | mipseb | mipsel | mipsle \
111 | mips16 \
112 | mips64 | mips64el \
113@@ -283,26 +287,23 @@ case $basic_machine in
114 | mips64vr5900 | mips64vr5900el \
115 | mipsisa32 | mipsisa32el \
116 | mipsisa32r2 | mipsisa32r2el \
117- | mipsisa32r6 | mipsisa32r6el \
118 | mipsisa64 | mipsisa64el \
119 | mipsisa64r2 | mipsisa64r2el \
120- | mipsisa64r6 | mipsisa64r6el \
121 | mipsisa64sb1 | mipsisa64sb1el \
122 | mipsisa64sr71k | mipsisa64sr71kel \
123- | mipsr5900 | mipsr5900el \
124 | mipstx39 | mipstx39el \
125 | mn10200 | mn10300 \
126 | moxie \
127 | mt \
128 | msp430 \
129 | nds32 | nds32le | nds32be \
130- | nios | nios2 | nios2eb | nios2el \
131+ | nios | nios2 \
132 | ns16k | ns32k \
133- | open8 | or1k | or1knd | or32 \
134+ | open8 \
135+ | or32 \
136 | pdp10 | pdp11 | pj | pjl \
137 | powerpc | powerpc64 | powerpc64le | powerpcle \
138 | pyramid \
139- | riscv32 | riscv64 \
140 | rl78 | rx \
141 | score \
142 | sh | sh[1234] | sh[24]a | sh[24]aeb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
143@@ -327,7 +328,7 @@ case $basic_machine in
144 c6x)
145 basic_machine=tic6x-unknown
146 ;;
147- m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | nvptx | picochip)
148+ m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | picochip)
149 basic_machine=$basic_machine-unknown
150 os=-none
151 ;;
152@@ -369,13 +370,13 @@ case $basic_machine in
153 | aarch64-* | aarch64_be-* \
154 | alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
155 | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
156- | alphapca5[67]-* | alpha64pca5[67]-* | arc-* | arceb-* \
157+ | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
158 | arm-* | armbe-* | armle-* | armeb-* | armv*-* \
159 | avr-* | avr32-* \
160 | be32-* | be64-* \
161 | bfin-* | bs2000-* \
162 | c[123]* | c30-* | [cjt]90-* | c4x-* \
163- | c8051-* | clipper-* | craynv-* | cydra-* \
164+ | clipper-* | craynv-* | cydra-* \
165 | d10v-* | d30v-* | dlx-* \
166 | elxsi-* \
167 | f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
168@@ -384,13 +385,11 @@ case $basic_machine in
169 | hexagon-* \
170 | i*86-* | i860-* | i960-* | ia64-* \
171 | ip2k-* | iq2000-* \
172- | k1om-* \
173 | le32-* | le64-* \
174 | lm32-* \
175 | m32c-* | m32r-* | m32rle-* \
176 | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
177- | m88110-* | m88k-* | maxq-* | mcore-* | metag-* \
178- | microblaze-* | microblazeel-* \
179+ | m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* \
180 | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
181 | mips16-* \
182 | mips64-* | mips64el-* \
183@@ -404,22 +403,18 @@ case $basic_machine in
184 | mips64vr5900-* | mips64vr5900el-* \
185 | mipsisa32-* | mipsisa32el-* \
186 | mipsisa32r2-* | mipsisa32r2el-* \
187- | mipsisa32r6-* | mipsisa32r6el-* \
188 | mipsisa64-* | mipsisa64el-* \
189 | mipsisa64r2-* | mipsisa64r2el-* \
190- | mipsisa64r6-* | mipsisa64r6el-* \
191 | mipsisa64sb1-* | mipsisa64sb1el-* \
192 | mipsisa64sr71k-* | mipsisa64sr71kel-* \
193- | mipsr5900-* | mipsr5900el-* \
194 | mipstx39-* | mipstx39el-* \
195 | mmix-* \
196 | mt-* \
197 | msp430-* \
198 | nds32-* | nds32le-* | nds32be-* \
199- | nios-* | nios2-* | nios2eb-* | nios2el-* \
200+ | nios-* | nios2-* \
201 | none-* | np1-* | ns16k-* | ns32k-* \
202 | open8-* \
203- | or1k*-* \
204 | orion-* \
205 | pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
206 | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* \
207@@ -793,15 +788,11 @@ case $basic_machine in
208 basic_machine=ns32k-utek
209 os=-sysv
210 ;;
211- microblaze*)
212+ microblaze)
213 basic_machine=microblaze-xilinx
214 ;;
215- mingw64)
216- basic_machine=x86_64-pc
217- os=-mingw64
218- ;;
219 mingw32)
220- basic_machine=i686-pc
221+ basic_machine=i386-pc
222 os=-mingw32
223 ;;
224 mingw32ce)
225@@ -829,10 +820,6 @@ case $basic_machine in
226 basic_machine=powerpc-unknown
227 os=-morphos
228 ;;
229- moxiebox)
230- basic_machine=moxie-unknown
231- os=-moxiebox
232- ;;
233 msdos)
234 basic_machine=i386-pc
235 os=-msdos
236@@ -841,7 +828,7 @@ case $basic_machine in
237 basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
238 ;;
239 msys)
240- basic_machine=i686-pc
241+ basic_machine=i386-pc
242 os=-msys
243 ;;
244 mvs)
245@@ -1032,11 +1019,7 @@ case $basic_machine in
246 basic_machine=i586-unknown
247 os=-pw32
248 ;;
249- rdos | rdos64)
250- basic_machine=x86_64-pc
251- os=-rdos
252- ;;
253- rdos32)
254+ rdos)
255 basic_machine=i386-pc
256 os=-rdos
257 ;;
258@@ -1363,29 +1346,29 @@ case $os in
259 -gnu* | -bsd* | -mach* | -minix* | -genix* | -ultrix* | -irix* \
260 | -*vms* | -sco* | -esix* | -isc* | -aix* | -cnk* | -sunos | -sunos[34]*\
261 | -hpux* | -unos* | -osf* | -luna* | -dgux* | -auroraux* | -solaris* \
262- | -sym* | -kopensolaris* | -plan9* \
263+ | -sym* | -kopensolaris* \
264 | -amigaos* | -amigados* | -msdos* | -newsos* | -unicos* | -aof* \
265 | -aos* | -aros* \
266 | -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
267 | -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
268 | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
269- | -bitrig* | -openbsd* | -solidbsd* \
270+ | -openbsd* | -solidbsd* \
271 | -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
272 | -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
273 | -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
274 | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
275 | -chorusos* | -chorusrdb* | -cegcc* \
276 | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
277- | -mingw32* | -mingw64* | -linux-gnu* | -linux-android* \
278- | -linux-newlib* | -linux-musl* | -linux-uclibc* \
279- | -uxpv* | -beos* | -mpeix* | -udk* | -moxiebox* \
280+ | -mingw32* | -linux-gnu* | -linux-android* \
281+ | -linux-newlib* | -linux-uclibc* \
282+ | -uxpv* | -beos* | -mpeix* | -udk* \
283 | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
284 | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
285 | -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
286 | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
287 | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
288 | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
289- | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es* | -tirtos*)
290+ | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es*)
291 # Remember, each alternative MUST END IN *, to match a version number.
292 ;;
293 -qnx*)
294@@ -1509,6 +1492,9 @@ case $os in
295 -aros*)
296 os=-aros
297 ;;
298+ -kaos*)
299+ os=-kaos
300+ ;;
301 -zvmoe)
302 os=-zvmoe
303 ;;
304@@ -1557,9 +1543,6 @@ case $basic_machine in
305 c4x-* | tic4x-*)
306 os=-coff
307 ;;
308- c8051-*)
309- os=-elf
310- ;;
311 hexagon-*)
312 os=-elf
313 ;;
diff --git a/testing/nut/nut-upsd.confd b/testing/nut/nut-upsd.confd
deleted file mode 100644
index ab4cb59564..0000000000
--- a/testing/nut/nut-upsd.confd
+++ /dev/null
@@ -1,3 +0,0 @@
1CONFIG=/etc/nut/nut.conf
2# Run IPv4 only, -6 for IPv6
3ARGS="-4 -u nut"
diff --git a/testing/nut/nut-upsd.initd b/testing/nut/nut-upsd.initd
deleted file mode 100644
index db1e4b1f70..0000000000
--- a/testing/nut/nut-upsd.initd
+++ /dev/null
@@ -1,53 +0,0 @@
1#!/sbin/openrc-run
2
3extra_started_commands="reload"
4
5pid_dir=/var/run/nut
6pidfile=/var/run/nut/upsd.pid
7upsd=/usr/sbin/upsd
8upsdrvctl=/usr/libexec/nut/upsdrvctl
9NAME=nut-server
10
11depend() {
12 use net
13 before nut-upsmon
14}
15
16start_pre()
17{
18 # Ensure that our dirs are correct
19 checkpath -d --owner root:nut --mode 0770 $pid_dir
20}
21
22start() {
23 ebegin "Starting upsd"
24
25 # Include NUT nut.conf
26 [ -r $CONFIG ] && . $CONFIG
27
28 # Explicitly require the configuration to be done in /etc/nut/nut.conf
29 # redundant with nut-client
30 if [ "x$MODE" = "xnone" -o -z "$MODE" ] ; then
31 eerror "$NAME disabled, please adjust the configuration to your needs"
32 eerror "Then set MODE to a suitable value in $CONFIG to enable it"
33 # exit success to avoid breaking the install process!
34 return 1
35 fi
36
37 ${upsdrvctl} -u nut start &>/dev/null
38 start-stop-daemon --start --pidfile ${pidfile} --exec ${upsd} -- ${ARGS}
39 eend $?
40}
41
42stop() {
43 ebegin "Stopping upsd"
44 start-stop-daemon --stop --pidfile ${pidfile}
45 ${upsdrvctl} -u nut stop &>/dev/null
46 eend $?
47}
48
49reload() {
50 ebegin "Reloading upsd"
51 start-stop-daemon --stop --signal HUP --pidfile ${pidfile}
52 eend $?
53}
diff --git a/testing/nut/nut-upsmon.confd b/testing/nut/nut-upsmon.confd
deleted file mode 100644
index ab4cb59564..0000000000
--- a/testing/nut/nut-upsmon.confd
+++ /dev/null
@@ -1,3 +0,0 @@
1CONFIG=/etc/nut/nut.conf
2# Run IPv4 only, -6 for IPv6
3ARGS="-4 -u nut"
diff --git a/testing/nut/nut-upsmon.initd b/testing/nut/nut-upsmon.initd
deleted file mode 100644
index 3c98c17d03..0000000000
--- a/testing/nut/nut-upsmon.initd
+++ /dev/null
@@ -1,43 +0,0 @@
1#!/sbin/openrc-run
2
3extra_started_commands="reload"
4
5pidfile=/var/run/upsmon.pid
6upsmon=/usr/sbin/upsmon
7NAME=nut-monitor
8
9depend() {
10 use net
11 after nut-upsd
12}
13
14start() {
15 ebegin "Starting upsmon"
16
17 # Include NUT nut.conf
18 [ -r $CONFIG ] && . $CONFIG
19
20 # Explicitly require the configuration to be done in /etc/nut/nut.conf
21 # redundant with nut-client
22 if [ "x$MODE" = "xnone" -o -z "$MODE" ] ; then
23 eerror "$NAME disabled, please adjust the configuration to your needs"
24 eerror "Then set MODE to a suitable value in $CONFIG to enable it"
25 # exit success to avoid breaking the install process!
26 return 1
27 fi
28
29 start-stop-daemon --start --pidfile ${pidfile} --exec ${upsmon} -- ${ARGS}
30 eend $?
31}
32
33stop() {
34 ebegin "Stopping upsmon"
35 start-stop-daemon --stop --pidfile ${pidfile}
36 eend $?
37}
38
39reload() {
40 ebegin "Reloading upsmon"
41 start-stop-daemon --stop --signal HUP --pidfile ${pidfile}
42 eend $?
43}
diff --git a/testing/nut/nut.confd b/testing/nut/nut.confd
new file mode 100644
index 0000000000..b24f2ff549
--- /dev/null
+++ b/testing/nut/nut.confd
@@ -0,0 +1,2 @@
1# -4 Run IPv4 only, -6 for IPv6
2#command_args="-4"
diff --git a/testing/nut/nut.pre-install b/testing/nut/nut.pre-install
index 707f98d53a..f55657454e 100644
--- a/testing/nut/nut.pre-install
+++ b/testing/nut/nut.pre-install
@@ -1,5 +1,10 @@
1#!/bin/sh 1#!/bin/sh
2 2
3if ! getent passwd nut; then
4 addgroup -S -g 84 nut 2>/dev/null
5 adduser -SDH -u 84 -h /var/run/nut -s /sbin/nologin -g nut nut 2>/dev/null
6fi
7
3adduser nut uucp 2>/dev/null 8adduser nut uucp 2>/dev/null
4 9
5exit 0 10exit 0
diff --git a/testing/nut/upsd.initd b/testing/nut/upsd.initd
new file mode 100644
index 0000000000..ccfac08fda
--- /dev/null
+++ b/testing/nut/upsd.initd
@@ -0,0 +1,39 @@
1#!/sbin/openrc-run
2
3name=nut-server
4pidfile=/var/run/nut/upsd.pid
5command=/usr/sbin/upsd
6required_files="/etc/nut/nut.conf /etc/nut/upsd.conf"
7extra_started_commands="reload"
8
9depend() {
10 use net
11}
12
13start_pre() {
14 . /etc/nut/nut.conf
15 case $MODE in
16 standalone|netserver)
17 checkpath -d --owner nut:nut --mode 750 ${pidfile%/*} || return 1
18 /usr/sbin/upsdrvctl start > /dev/null
19 ;;
20 none)
21 eerror "$name disabled, please adjust the configuration to your needs"
22 eerror "Then set MODE to a suitable value in /etc/nut/nut.conf to enable it"
23 return 1
24 ;;
25 *)
26 return 1
27 ;;
28 esac
29}
30
31stop_post() {
32 /usr/sbin/upsdrvctl stop > /dev/null
33}
34
35reload() {
36 ebegin "Reloading $name"
37 start-stop-daemon --signal HUP --pidfile ${pidfile}
38 eend $?
39}
diff --git a/testing/nut/upsmon.initd b/testing/nut/upsmon.initd
new file mode 100644
index 0000000000..468e514111
--- /dev/null
+++ b/testing/nut/upsmon.initd
@@ -0,0 +1,34 @@
1#!/sbin/openrc-run
2
3name=nut-monitor
4pidfile=/var/run/upsmon.pid
5command=/usr/sbin/upsmon
6required_files="/etc/nut/nut.conf /etc/nut/upsmon.conf"
7extra_started_commands="reload"
8
9depend() {
10 use net
11 . /etc/nut/nut.conf
12 case $MODE in
13 standalone|netserver)
14 need nut-upsd
15 ;;
16 esac
17}
18
19start_pre() {
20 . /etc/nut/nut.conf
21 case $MODE in
22 none)
23 eerror "$name disabled, please adjust the configuration to your needs"
24 eerror "Then set MODE to a suitable value in /etc/nut/nut.conf to enable it"
25 return 1
26 ;;
27 esac
28}
29
30reload() {
31 ebegin "Reloading $name"
32 start-stop-daemon --signal HUP --pidfile ${pidfile}
33 eend $?
34}