aboutsummaryrefslogtreecommitdiff
path: root/testing/oh-my-zsh
diff options
context:
space:
mode:
authorOrson Teodoro <orsonteodoro@hotmail.com>2018-02-08 11:17:27 -0800
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-08 23:00:49 +0000
commit87275efd72411640edf25486078adc67a2f7a94a (patch)
tree9ce003c9c8c126e40710d21c56fa7ddfd1dc22cd /testing/oh-my-zsh
parent5869e1f13a8de4ffa909bbccf51f995d425b25e8 (diff)
downloadalpine_aports-87275efd72411640edf25486078adc67a2f7a94a.tar.bz2
alpine_aports-87275efd72411640edf25486078adc67a2f7a94a.tar.xz
alpine_aports-87275efd72411640edf25486078adc67a2f7a94a.zip
testing/oh-my-zsh: new aport
remove || return 1. remove licenses copy for osi licenses. clean up doc(). update checksum reorder default_doc move sed patch into install-path.patch. delete doc(), delete prepare(). use install cmd. remove unused variables. remove extra new line. put reason why check is disabled. force 80 columns
Diffstat (limited to 'testing/oh-my-zsh')
-rw-r--r--testing/oh-my-zsh/APKBUILD32
-rw-r--r--testing/oh-my-zsh/install-path.patch11
-rw-r--r--testing/oh-my-zsh/oh-my-zsh.post-install2
-rw-r--r--testing/oh-my-zsh/oh-my-zsh.post-upgrade2
4 files changed, 47 insertions, 0 deletions
diff --git a/testing/oh-my-zsh/APKBUILD b/testing/oh-my-zsh/APKBUILD
new file mode 100644
index 0000000000..7e31ffd0a7
--- /dev/null
+++ b/testing/oh-my-zsh/APKBUILD
@@ -0,0 +1,32 @@
1# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
2# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
3
4pkgname=oh-my-zsh
5pkgver=0_git20180122
6pkgrel=0
7pkgdesc="A delightful community-driven framework for managing your zsh \
8configuration that includes plugins and themes."
9url="http://ohmyz.sh/"
10arch="noarch"
11license="MIT"
12depends="zsh powerline-extra-symbols"
13subpackages="$pkgname-doc"
14options="!check" # no upstream tests
15_gitrev="37c2d0ddd751e15d0c87a51e2d9f9849093571dc"
16install="$pkgname.post-install $pkgname.post-upgrade"
17source="$pkgname-$pkgver.zip::https://github.com/robbyrussell/$pkgname/archive/$_gitrev.zip
18 install-path.patch"
19builddir="$srcdir/"$pkgname-$_gitrev
20
21package() {
22 cd "$builddir"
23 install -d "$pkgdir"/usr/share/oh-my-zsh/ \
24 "$pkgdir"/usr/share/doc/$pkgname/
25 chmod 755 $(find . -type d)
26 mv * "$pkgdir"/usr/share/oh-my-zsh/
27 install -t "$pkgdir"/usr/share/doc/$pkgname/ \
28 "$pkgdir"/usr/share/oh-my-zsh/README.md
29}
30
31sha512sums="51724f26ff7a59a1c9e517677b4a45750326ac4ad9f6b3579ed009253f3d37dedafd92c7d8e921bb456ae6862259173f8c9ea5fa562ee2a1c829b09f8f49dba0 oh-my-zsh-0_git20180122.zip
3256bcb688489dcf74ba09a2924bd029786273781cf801c990f4ac2ccf53e4d54143f6c59ff49d0fa11189e07f16665ab7329dead0b9853da7bf1480caa419bf15 install-path.patch"
diff --git a/testing/oh-my-zsh/install-path.patch b/testing/oh-my-zsh/install-path.patch
new file mode 100644
index 0000000000..3885996449
--- /dev/null
+++ b/testing/oh-my-zsh/install-path.patch
@@ -0,0 +1,11 @@
1--- a/templates/zshrc.zsh-template.orig
2+++ b/templates/zshrc.zsh-template
3@@ -2,7 +2,7 @@
4 # export PATH=$HOME/bin:/usr/local/bin:$PATH
5
6 # Path to your oh-my-zsh installation.
7-export ZSH=$HOME/.oh-my-zsh
8+export ZSH=/usr/share/
9
10 # Set name of the theme to load. Optionally, if you set this to "random"
11 # it'll load a random theme each time that oh-my-zsh is loaded.
diff --git a/testing/oh-my-zsh/oh-my-zsh.post-install b/testing/oh-my-zsh/oh-my-zsh.post-install
new file mode 100644
index 0000000000..a71c23b685
--- /dev/null
+++ b/testing/oh-my-zsh/oh-my-zsh.post-install
@@ -0,0 +1,2 @@
1#!/bin/sh
2echo "You need to copy the contents of /usr/share/oh-my-zsh/templates/zshrc.zsh-template in your ~/.zshrc. Then, you should edit it."
diff --git a/testing/oh-my-zsh/oh-my-zsh.post-upgrade b/testing/oh-my-zsh/oh-my-zsh.post-upgrade
new file mode 100644
index 0000000000..a71c23b685
--- /dev/null
+++ b/testing/oh-my-zsh/oh-my-zsh.post-upgrade
@@ -0,0 +1,2 @@
1#!/bin/sh
2echo "You need to copy the contents of /usr/share/oh-my-zsh/templates/zshrc.zsh-template in your ~/.zshrc. Then, you should edit it."