aboutsummaryrefslogtreecommitdiff
path: root/unmaintained/jemalloc
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-10 19:47:55 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-10 19:47:55 +0000
commit21836d30f5db21f9f3bb4fe3d70ddd4802ed9541 (patch)
tree2e9ef1a2e6b6a1eadcec17985b56ff9eaf9bd495 /unmaintained/jemalloc
parent10a2b3a8cd75ab13660bef4a97f351e031fba917 (diff)
downloadalpine_aports-21836d30f5db21f9f3bb4fe3d70ddd4802ed9541.tar.bz2
alpine_aports-21836d30f5db21f9f3bb4fe3d70ddd4802ed9541.tar.xz
alpine_aports-21836d30f5db21f9f3bb4fe3d70ddd4802ed9541.zip
main/jemalloc: move to unmaintained
is no longer used by any aport
Diffstat (limited to 'unmaintained/jemalloc')
-rw-r--r--unmaintained/jemalloc/APKBUILD40
-rw-r--r--unmaintained/jemalloc/jemalloc-no-pprof.patch11
2 files changed, 51 insertions, 0 deletions
diff --git a/unmaintained/jemalloc/APKBUILD b/unmaintained/jemalloc/APKBUILD
new file mode 100644
index 0000000000..ca16608545
--- /dev/null
+++ b/unmaintained/jemalloc/APKBUILD
@@ -0,0 +1,40 @@
1# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
2# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
3pkgname=jemalloc
4pkgver=5.1.0
5pkgrel=0
6pkgdesc="A general purpose malloc(3) implementation"
7url="http://jemalloc.net/"
8arch="all !armv7"
9license="BSD-2-Clause"
10subpackages="$pkgname-dev $pkgname-doc"
11source="$pkgname-$pkgver.tar.bz2::https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
12 jemalloc-no-pprof.patch
13 "
14
15build() {
16 cd "$builddir"
17 ./configure \
18 --build=$CBUILD \
19 --host=$CHOST \
20 --prefix=/usr \
21 --sysconfdir=/etc \
22 --mandir=/usr/share/man \
23 --infodir=/usr/share/info \
24 --localstatedir=/var \
25 --disable-syscall
26 make
27}
28
29check() {
30 cd "$builddir"
31 make check
32}
33
34package() {
35 cd "$builddir"
36 make DESTDIR="$pkgdir" install
37}
38
39sha512sums="d9abebe54d303ca931b8c31c1033f23ff5fb060f2377ec8386f4d79c352e65c78ed34f680c352dac14f7d7115d10245782d553d988bc13df2eb34a2f0942ef6f jemalloc-5.1.0.tar.bz2
401e59e6e3bd98be3be12a2619acf213445906c1f70d5e06fbfb98c1409c93486934ab53d58709a05e0c109e5ba9eab16d2110163e173de22ef2dc969d1cde9274 jemalloc-no-pprof.patch"
diff --git a/unmaintained/jemalloc/jemalloc-no-pprof.patch b/unmaintained/jemalloc/jemalloc-no-pprof.patch
new file mode 100644
index 0000000000..3415878e67
--- /dev/null
+++ b/unmaintained/jemalloc/jemalloc-no-pprof.patch
@@ -0,0 +1,11 @@
1--- a/Makefile.in
2+++ b/Makefile.in
3@@ -467,7 +467,7 @@
4
5 install_doc: install_doc_html install_doc_man
6
7-install: install_bin install_include install_lib install_doc
8+install: install_include install_lib install_doc
9
10 tests_unit: $(TESTS_UNIT:$(srcroot)%.c=$(objroot)%$(EXE))
11 tests_integration: $(TESTS_INTEGRATION:$(srcroot)%.c=$(objroot)%$(EXE)) $(TESTS_INTEGRATION_CPP:$(srcroot)%.cpp=$(objroot)%$(EXE))