aboutsummaryrefslogtreecommitdiff
path: root/unmaintained/jemalloc
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2020-06-08 22:06:06 +0000
committerMilan P. Stanić <mps@arvanta.net>2020-06-08 22:06:06 +0000
commit389389f7349c3847f1d78e4876f680a78ebd551e (patch)
treec3b0810106497390d63f53fb65293b009dd184b6 /unmaintained/jemalloc
parent8efa6cf1b4df1d0e1f85d3b5590de88cf24ce6d2 (diff)
downloadalpine_aports-389389f7349c3847f1d78e4876f680a78ebd551e.tar.bz2
alpine_aports-389389f7349c3847f1d78e4876f680a78ebd551e.tar.xz
alpine_aports-389389f7349c3847f1d78e4876f680a78ebd551e.zip
unmaintained/jemalloc: fix cross compiling
Diffstat (limited to 'unmaintained/jemalloc')
-rw-r--r--unmaintained/jemalloc/APKBUILD56
1 files changed, 30 insertions, 26 deletions
diff --git a/unmaintained/jemalloc/APKBUILD b/unmaintained/jemalloc/APKBUILD
index ca16608545..991809b22b 100644
--- a/unmaintained/jemalloc/APKBUILD
+++ b/unmaintained/jemalloc/APKBUILD
@@ -1,40 +1,44 @@
1# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
2# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch> 1# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
2# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
3# Contributor: Duncan Bellamy <dunk@denkimushi.com>
3pkgname=jemalloc 4pkgname=jemalloc
4pkgver=5.1.0 5pkgver=5.2.1
5pkgrel=0 6pkgrel=0
6pkgdesc="A general purpose malloc(3) implementation" 7pkgdesc="general purpose malloc(3) implementation that emphasizes fragmentation avoidance and scalable concurrency support"
7url="http://jemalloc.net/" 8url="http://jemalloc.net"
8arch="all !armv7" 9arch="all"
9license="BSD-2-Clause" 10license="custom"
11makedepends="build-base autoconf libxslt docbook-xsl"
10subpackages="$pkgname-dev $pkgname-doc" 12subpackages="$pkgname-dev $pkgname-doc"
11source="$pkgname-$pkgver.tar.bz2::https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2 13source="https://github.com/jemalloc/jemalloc/releases/download/$pkgver/jemalloc-$pkgver.tar.bz2"
12 jemalloc-no-pprof.patch
13 "
14
15build() { 14build() {
16 cd "$builddir" 15 local _pgs
16 case "$CARCH" in
17 x86|x86_64) _pgs=12 ;;
18 ppc64le) export CPPFLAGS="$CPPFLAGS -maltivec -mabi=altivec" && _pgs=16 ;;
19 *) _pgs=16 ;;
20 esac
21
22 echo "$pkgver" > VERSION
23 local _xslroot=$(find /usr/share/xml/docbook -iname "xsl-stylesheets-*")
24 autoconf
17 ./configure \ 25 ./configure \
18 --build=$CBUILD \ 26 --enable-xmalloc \
19 --host=$CHOST \ 27 --prefix="$pkgdir"/usr \
20 --prefix=/usr \
21 --sysconfdir=/etc \
22 --mandir=/usr/share/man \
23 --infodir=/usr/share/info \
24 --localstatedir=/var \ 28 --localstatedir=/var \
25 --disable-syscall 29 --sysconfdir=/etc \
26 make 30 --with-xslroot="$_xslroot" \
31 --with-lg-page="$_pgs" \
32 --with-lg-hugepage=21
33 make all dist
27} 34}
28 35
29check() { 36check() {
30 cd "$builddir" 37 make tests
31 make check
32} 38}
33 39
34package() { 40package() {
35 cd "$builddir" 41 make install
36 make DESTDIR="$pkgdir" install 42 install -Dm644 "$builddir"/COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
37} 43}
38 44sha512sums="0bbb77564d767cef0c6fe1b97b705d368ddb360d55596945aea8c3ba5889fbce10479d85ad492c91d987caacdbbdccc706aa3688e321460069f00c05814fae02 jemalloc-5.2.1.tar.bz2"
39sha512sums="d9abebe54d303ca931b8c31c1033f23ff5fb060f2377ec8386f4d79c352e65c78ed34f680c352dac14f7d7115d10245782d553d988bc13df2eb34a2f0942ef6f jemalloc-5.1.0.tar.bz2
401e59e6e3bd98be3be12a2619acf213445906c1f70d5e06fbfb98c1409c93486934ab53d58709a05e0c109e5ba9eab16d2110163e173de22ef2dc969d1cde9274 jemalloc-no-pprof.patch"