aboutsummaryrefslogtreecommitdiff
path: root/unmaintained/lxpanel
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 07:51:13 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-11 16:16:43 +0000
commit640b988f625ce77cdeb7cc8c58bf3ff1a560b01c (patch)
treed2173cc1fa81b55d1fa2dd6a01f241856aa3a172 /unmaintained/lxpanel
parent9e11a23e5aabf36ed1e2d3e7c235d97b4eb9cb30 (diff)
downloadalpine_aports-640b988f625ce77cdeb7cc8c58bf3ff1a560b01c.tar.bz2
alpine_aports-640b988f625ce77cdeb7cc8c58bf3ff1a560b01c.tar.xz
alpine_aports-640b988f625ce77cdeb7cc8c58bf3ff1a560b01c.zip
unmaintained/lxpanel: move from testing
Diffstat (limited to 'unmaintained/lxpanel')
-rw-r--r--unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch21
-rw-r--r--unmaintained/lxpanel/APKBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch b/unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch
new file mode 100644
index 0000000000..0932a4be25
--- /dev/null
+++ b/unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch
@@ -0,0 +1,21 @@
1--- a/plugins/netstat/devproc.c
2+++ b/plugins/netstat/devproc.c
3@@ -25,15 +25,15 @@
4 #include <net/if.h>
5 #include <net/if_arp.h>
6 #include <arpa/inet.h>
7-#include <linux/sockios.h>
8-#include <linux/types.h>
9-#include <linux/ethtool.h>
10 #include <iwlib.h>
11 #include "nsconfig.h"
12 #include "netstat.h"
13 #include "statusicon.h"
14 #include "devproc.h"
15 #include "dbg.h"
16+#include <linux/sockios.h>
17+#include <linux/types.h>
18+#include <linux/ethtool.h>
19
20 /* network device list */
21 static void netproc_netdevlist_add(NETDEVLIST_PTR *netdev_list,
diff --git a/unmaintained/lxpanel/APKBUILD b/unmaintained/lxpanel/APKBUILD
new file mode 100644
index 0000000000..3916ed09ce
--- /dev/null
+++ b/unmaintained/lxpanel/APKBUILD
@@ -0,0 +1,38 @@
1# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
2# Maintainer:
3
4pkgname=lxpanel
5pkgver=0.9.3
6pkgrel=1
7pkgdesc='Lightweight X11 desktop panel'
8arch='all'
9url='https://lxde.org/'
10license='GPL'
11makedepends='gtk+2.0-dev alsa-lib-dev menu-cache-dev libwnck-dev
12 wireless-tools-dev docbook-xml docbook-xsl intltool libfm-dev
13 linux-headers libxml2-dev keybinder-dev'
14subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
15source="https://downloads.sourceforge.net/sourceforge/lxde/$pkgname-$pkgver.tar.xz
16 10-devproc-lxpanel-0.6.2.patch"
17
18builddir="$srcdir"/${pkgname}-${pkgver}
19
20build() {
21 cd "$builddir"
22 ./configure \
23 --prefix=/usr \
24 --sysconfdir=/etc \
25 --mandir=/usr/share/man \
26 --infodir=/usr/share/info \
27 --localstatedir=/var \
28 --disable-silent-rules
29 make
30}
31
32package() {
33 cd "$builddir"
34 make DESTDIR="$pkgdir" install
35}
36
37sha512sums="c6aea97f66ee1d576822fda0bf1aed3849b3c74bab856816b7d23331e48b26005f1ba12eddcc0abbf5a6f08add3cb4a0674ccd13f118cec0b6294edd6f1b2343 lxpanel-0.9.3.tar.xz
38198174624d27198dc229a676d9cee1f56ee4528a5fd8dddf20ed474d3731c90e7f7ba706e3ffb8c8d0b200caece83aa0f3f365726fbf8ad6733996d2c9522914 10-devproc-lxpanel-0.6.2.patch"