aboutsummaryrefslogtreecommitdiff
path: root/unmaintained
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-05-30 17:25:14 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-05-30 17:25:14 +0200
commit7a86b39bfd5c67655a8d993b8d9d30b1d3d59280 (patch)
treed11bb8857f543576c5661c0b6a901c9503651125 /unmaintained
parentb0d2c2ccc915d9aaf2ec407a5b28051271300f47 (diff)
downloadalpine_aports-7a86b39bfd5c67655a8d993b8d9d30b1d3d59280.tar.bz2
alpine_aports-7a86b39bfd5c67655a8d993b8d9d30b1d3d59280.tar.xz
alpine_aports-7a86b39bfd5c67655a8d993b8d9d30b1d3d59280.zip
unmaintained/getmail: move from testing
No python3 support and doesn't seem to happen soon [0]. If python3 support is added at some point, this aport can be moved back to testing. [0]: https://marc.info/?l=getmail&m=154998883315349&w=2
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/getmail/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/unmaintained/getmail/APKBUILD b/unmaintained/getmail/APKBUILD
new file mode 100644
index 0000000000..f68d69c598
--- /dev/null
+++ b/unmaintained/getmail/APKBUILD
@@ -0,0 +1,27 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
2# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
3# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
4pkgname=getmail
5pkgver=5.14
6pkgrel=0
7pkgdesc="POP3, IMAP4, and SDPS mail retriever with Maildir delivery"
8url="http://pyropus.ca/software/getmail/"
9arch="noarch"
10license="GPL-2.0-only"
11depends="python2"
12makedepends="python2-dev"
13subpackages="$pkgname-doc"
14options="!check" # contains no tests
15source="http://pyropus.ca/software/getmail/old-versions/getmail-$pkgver.tar.gz"
16
17build() {
18 python2 setup.py build
19}
20
21package() {
22 python2 setup.py install --prefix=/usr --root="$pkgdir"
23 # fix some broken shebang calls
24 sed -i -e "s|#![ ]*/usr/bin/env python2\.3|#!/usr/bin/env python2|" $(find $pkgdir -name '*.py')
25}
26
27sha512sums="0646864af56fc044525d38088164c2c026a8f29b231c25c9cfe9aa922b1e5170cf49c63874da9bd593b49be6ed822bd4da7ea4ebfbb59cfa6e1658e2b565c184 getmail-5.14.tar.gz"