aboutsummaryrefslogtreecommitdiff
path: root/community/iotop-c/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/iotop-c/APKBUILD')
-rw-r--r--community/iotop-c/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/iotop-c/APKBUILD b/community/iotop-c/APKBUILD
new file mode 100644
index 0000000000..5f218c836b
--- /dev/null
+++ b/community/iotop-c/APKBUILD
@@ -0,0 +1,25 @@
1# Contributor: Milan P. Stanić <mps@arvanta.net>
2# Maintainer: Milan P. Stanić <mps@arvanta.net>
3pkgname=iotop-c
4pkgver=1.14
5pkgrel=0
6pkgdesc="simple top-like I/O monitor (implemented in C)"
7url="https://github.com/Tomas-M/iotop"
8arch="all"
9license="GPL-2.0-or-later"
10options="!check" # no tests
11depends="!iotop"
12makedepends="linux-headers ncurses-dev coreutils"
13subpackages="$pkgname-doc"
14source="$pkgname-$pkgver.tar.gz::https://github.com/Tomas-M/iotop/archive/v$pkgver.tar.gz"
15builddir="$srcdir/iotop-$pkgver"
16
17build() {
18 make
19}
20
21package() {
22 make DESTDIR=$pkgdir install
23}
24
25sha512sums="4c40d38791df342519d46bb0945095621e1a90b3b5eb1d51edd93ec4e3561917c84d1dea7965367256f2394fcfe41e1d30e7527ba825848afed39265ee14a360 iotop-c-1.14.tar.gz"