aboutsummaryrefslogtreecommitdiff
path: root/community/supertuxkart/find-directfb-include.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/supertuxkart/find-directfb-include.patch')
-rw-r--r--community/supertuxkart/find-directfb-include.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/supertuxkart/find-directfb-include.patch b/community/supertuxkart/find-directfb-include.patch
new file mode 100644
index 0000000000..e0b1f7a8df
--- /dev/null
+++ b/community/supertuxkart/find-directfb-include.patch
@@ -0,0 +1,19 @@
1diff --git a/CMakeLists.txt b/CMakeLists.txt
2index e4db9ca94..313ee4c9e 100644
3--- a/CMakeLists.txt
4+++ b/CMakeLists.txt
5@@ -295,11 +295,13 @@ if (NOT SERVER_ONLY)
6 # SDL2
7 find_library(SDL2_LIBRARY NAMES SDL2 libSDL2)
8 find_path(SDL2_INCLUDEDIR NAMES SDL.h PATH_SUFFIXES SDL2 include/SDL2 include PATHS)
9+ find_path(DIRECTFB_INCLUDEDIR NAMES directfb.h directfb++.h PATH_SUFFIXES directfb include/directfb include PATHS)
10 if (NOT SDL2_LIBRARY OR NOT SDL2_INCLUDEDIR)
11 message(FATAL_ERROR "SDL2 not found. "
12 "SDL2 is required to handle gamepad in SuperTuxKart.")
13 else()
14- include_directories("${SDL2_INCLUDEDIR}")
15+ include_directories(${SDL2_INCLUDEDIR})
16+ include_directories(${DIRECTFB_INCLUDEDIR})
17 MESSAGE(STATUS "Use system SDL2: ${SDL2_LIBRARY}")
18 endif()
19 endif()