aboutsummaryrefslogtreecommitdiff
path: root/main/fuse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fuse/APKBUILD')
-rw-r--r--main/fuse/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/main/fuse/APKBUILD b/main/fuse/APKBUILD
new file mode 100644
index 0000000000..5f2d4eb61e
--- /dev/null
+++ b/main/fuse/APKBUILD
@@ -0,0 +1,62 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=fuse
3pkgver=2.8.1
4pkgrel=1
5pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
6url="http://fuse.sourceforge.net/"
7license="GPL2"
8depends=
9makedepends="pkgconfig libiconv-dev gettext-dev
10 autoconf automake libtool"
11install=
12subpackages="$pkgname-dev"
13source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
14 fuse-iconv.patch
15 fuse.initd"
16
17
18_builddir="$srcdir"/$pkgname-$pkgver
19
20prepare() {
21 cd "$_builddir"
22 patch -p1 -i "$srcdir"/fuse-iconv.patch || return 1
23 aclocal -I m4 && libtoolize && autoconf && automake
24}
25
26build() {
27 cd "$_builddir"
28 ./configure --prefix=/usr \
29 --enable-lib \
30 --enable-util \
31 --bindir=/bin \
32 || return 1
33 make || return 1
34}
35
36package() {
37 cd "$_builddir"
38 make DESTDIR="$pkgdir" install || return 1
39
40 rm -rf "$pkgdir"/dev
41 rm -rf "$pkgdir"/etc/init.d
42
43 install -Dm755 "$srcdir"/fuse.initd "$pkgdir"/etc/init.d/fuse
44 # create config
45 install -d "$pkgdir"/etc
46 cat >"$pkgdir"/etc/fuse.conf << _EOF_
47# Set the maximum number of FUSE mounts allowed to non-root users.
48# The default is 1000.
49#
50#mount_max = 1000
51
52# Allow non-root users to specify the 'allow_other' or 'allow_root'
53# mount options.
54#
55#user_allow_other
56_EOF_
57
58}
59
60md5sums="0e3505ce90155983f1bc995eb2cf6fa7 fuse-2.8.1.tar.gz
61e5183506aabc5bf7795da52953d38888 fuse-iconv.patch
625983726cfabf0830dffbbbf9a3abcddc fuse.initd"