aboutsummaryrefslogtreecommitdiff
path: root/testing/pegtl/ignore-type-limits-error.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pegtl/ignore-type-limits-error.patch')
-rw-r--r--testing/pegtl/ignore-type-limits-error.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/testing/pegtl/ignore-type-limits-error.patch b/testing/pegtl/ignore-type-limits-error.patch
new file mode 100644
index 0000000000..5407c932c5
--- /dev/null
+++ b/testing/pegtl/ignore-type-limits-error.patch
@@ -0,0 +1,19 @@
1Reason: Ignore type-limits error
2Upstream: No
3
4This issue is fixed by upstream in https://github.com/taocpp/PEGTL/commit/a3a292c2ba66bf09b4adc4cee8fcdfb1b1386067,
5but the patch does not apply to current codebase (version 2.8.3).
6
7diff --git a/CMakeLists.txt b/CMakeLists.txt
8index 0fe7e8e7..a3fedc20 100644
9--- a/CMakeLists.txt
10+++ b/CMakeLists.txt
11@@ -7,6 +7,8 @@ set(PEGTL_VERSION "${CMAKE_MATCH_1}")
12
13 project(pegtl VERSION ${PEGTL_VERSION} LANGUAGES CXX)
14
15+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=type-limits")
16+
17 if(${PROJECT_NAME}_FOUND)
18 # Multiple versions of PEGTL can't co-exist
19 if(NOT ${PROJECT_NAME}_VERSION STREQUAL ${PROJECT_VERSION})