aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-10-10 21:09:53 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-10-11 18:55:29 +0000
commit2208ece92c5dd18ef92d0ec3e49f64f124b8d8b4 (patch)
tree55d291ddde30570fde22692d65503f6f75d8b6ec
parent3c2ea94e1233e388aa92f48655d59eac5adfd1d1 (diff)
downloadalpine_aports-2208ece92c5dd18ef92d0ec3e49f64f124b8d8b4.tar.bz2
alpine_aports-2208ece92c5dd18ef92d0ec3e49f64f124b8d8b4.tar.xz
alpine_aports-2208ece92c5dd18ef92d0ec3e49f64f124b8d8b4.zip
community/firefox: sort options
-rw-r--r--community/firefox/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/firefox/APKBUILD b/community/firefox/APKBUILD
index b03c639b8f..e526401670 100644
--- a/community/firefox/APKBUILD
+++ b/community/firefox/APKBUILD
@@ -243,53 +243,56 @@ build() {
243 _rust_simd="--disable-rust-simd" 243 _rust_simd="--disable-rust-simd"
244 _low_mem_flags="--disable-debug-symbols --disable-debug" 244 _low_mem_flags="--disable-debug-symbols --disable-debug"
245 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0" 245 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
246 ;; 246 ;;
247 x86) 247 x86)
248 _low_mem_flags="--disable-debug-symbols --disable-debug" 248 _low_mem_flags="--disable-debug-symbols --disable-debug"
249 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0" 249 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
250 ;; 250 ;;
251 *) _rust_simd="--enable-rust-simd" ;; 251 *) _rust_simd="--enable-rust-simd" ;;
252 esac 252 esac
253 253
254 ../configure \ 254 ../configure \
255 --prefix=/usr \ 255 --prefix=/usr \
256 $_arch_config \ 256 $_arch_config \
257 $_low_mem_flags \
258 $_rust_simd \
259 \
257 --disable-crashreporter \ 260 --disable-crashreporter \
258 --disable-gold \ 261 --disable-gold \
259 --disable-install-strip \ 262 --disable-install-strip \
260 --disable-jemalloc \ 263 --disable-jemalloc \
261 --disable-profiling \ 264 --disable-profiling \
262 --disable-pulseaudio \ 265 --disable-pulseaudio \
263 --enable-dbus \
264 --enable-necko-wifi \
265 --disable-strip \ 266 --disable-strip \
266 --disable-tests \ 267 --disable-tests \
267 --disable-updater \ 268 --disable-updater \
269 \
268 --enable-alsa \ 270 --enable-alsa \
271 --enable-cdp \
272 --enable-dbus \
269 --enable-default-toolkit=cairo-gtk3-wayland \ 273 --enable-default-toolkit=cairo-gtk3-wayland \
274 --enable-ffmpeg \
275 --enable-hardening \
276 --enable-necko-wifi \
270 --enable-official-branding \ 277 --enable-official-branding \
271 --enable-optimize="$CFLAGS -O2" \ 278 --enable-optimize="$CFLAGS -O2" \
272 --enable-system-ffi \
273 --enable-ffmpeg \
274 --enable-smoosh \ 279 --enable-smoosh \
275 $_rust_simd \ 280 --enable-system-ffi \
276 $_low_mem_flags \
277 --enable-hardening \
278 --enable-system-pixman \ 281 --enable-system-pixman \
282 \
279 --with-system-ffi \ 283 --with-system-ffi \
280 --with-system-icu \ 284 --with-system-icu \
285 --with-system-jpeg \
281 --with-system-libevent \ 286 --with-system-libevent \
287 --with-system-libvpx \
282 --with-system-nspr \ 288 --with-system-nspr \
283 --with-system-nss \ 289 --with-system-nss \
284 --with-system-pixman \ 290 --with-system-pixman \
285 --with-system-png \ 291 --with-system-png \
286 --with-system-zlib \
287 --with-system-libvpx \
288 --with-system-webp \ 292 --with-system-webp \
289 --with-system-jpeg \ 293 --with-system-zlib \
290 --with-clang-path=/usr/bin/clang \ 294 --with-clang-path=/usr/bin/clang \
291 --with-libclang-path=/usr/lib \ 295 --with-libclang-path=/usr/lib
292 --enable-cdp
293 make 296 make
294} 297}
295 298