aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-29 13:00:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-29 13:00:11 +0000
commit66a20b26abf0227bafcc178ebe106827c8d148ff (patch)
tree24f5c8c8e9ff0206b588c240f191d4ee2f71a446
parent87d28613b8a0b2e8f3ccaa7ed5ad689a25d1a852 (diff)
downloadalpine_aports-66a20b26abf0227bafcc178ebe106827c8d148ff.tar.bz2
alpine_aports-66a20b26abf0227bafcc178ebe106827c8d148ff.tar.xz
alpine_aports-66a20b26abf0227bafcc178ebe106827c8d148ff.zip
main/gnome-bluetooth: upgrade to 3.10.0
-rw-r--r--main/gnome-bluetooth/APKBUILD38
1 files changed, 22 insertions, 16 deletions
diff --git a/main/gnome-bluetooth/APKBUILD b/main/gnome-bluetooth/APKBUILD
index a0816b29ea..dcbb98ec89 100644
--- a/main/gnome-bluetooth/APKBUILD
+++ b/main/gnome-bluetooth/APKBUILD
@@ -1,20 +1,18 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=gnome-bluetooth 2pkgname=gnome-bluetooth
3pkgver=2.32.0 3pkgver=3.10.0
4pkgrel=4 4pkgrel=0
5pkgdesc="The GNOME Bluetooth Subsystem" 5pkgdesc="The GNOME Bluetooth Subsystem"
6url="http://live.gnome.org/GnomeBluetooth" 6url="http://live.gnome.org/GnomeBluetooth"
7arch="all" 7arch="all"
8license="GPL LGPL" 8license="GPL LGPL"
9depends="hicolor-icon-theme obexd-client obex-data-server" 9depends="hicolor-icon-theme bluez>=5"
10makedepends="intltool py-gtk gobject-introspection-dev libunique-dev 10makedepends="intltool py-gtk gobject-introspection-dev libunique-dev
11 libnotify-dev libxi-dev libxslt py-libxml2 gnome-doc-utils 11 libnotify-dev libxi-dev libxslt py-libxml2 gnome-doc-utils
12 dbus-glib-dev gtk+2.0-dev" 12 dbus-glib-dev gtk+3.0-dev itstool"
13install= 13install=
14subpackages="$pkgname-dev $pkgname-doc" 14subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
15source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.bz2 15source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.xz
16 nogeoclue.patch
17 libnotify-0.7.patch
18 61-gnome-bluetooth-rfkill.rules" 16 61-gnome-bluetooth-rfkill.rules"
19 17
20_builddir="$srcdir"/$pkgname-$pkgver 18_builddir="$srcdir"/$pkgname-$pkgver
@@ -33,7 +31,7 @@ prepare() {
33 31
34build() { 32build() {
35 cd "$_builddir" 33 cd "$_builddir"
36 ./configure \ 34 DATADIRNAME=share ./configure \
37 --build=$CBUILD \ 35 --build=$CBUILD \
38 --host=$CHOST \ 36 --host=$CHOST \
39 --prefix=/usr \ 37 --prefix=/usr \
@@ -41,10 +39,8 @@ build() {
41 --localstatedir=/var \ 39 --localstatedir=/var \
42 --disable-desktop-update \ 40 --disable-desktop-update \
43 --disable-icon-update \ 41 --disable-icon-update \
44 --disable-nautilus-sendto \
45 --disable-schemas-compile \ 42 --disable-schemas-compile \
46 --disable-introspection \ 43 --enable-introspection \
47 --disable-scrollkeeper \
48 || return 1 44 || return 1
49 make 45 make
50} 46}
@@ -52,12 +48,22 @@ build() {
52package() { 48package() {
53 cd "$_builddir" 49 cd "$_builddir"
54 make DESTDIR="$pkgdir" install || return 1 50 make DESTDIR="$pkgdir" install || return 1
55 rm "$pkgdir"/usr/lib/*.la 51 rm "$pkgdir"/usr/lib/*.la \
52 "$pkgdir"/usr/lib/gnome-bluetooth/plugins/*.la \
53 || return 1
56 install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \ 54 install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
57 "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules" 55 "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
58} 56}
59 57
60md5sums="f129686fe46c4c98eb70a0cc85d59cae gnome-bluetooth-2.32.0.tar.bz2 58libs() {
615ed6f59d02b45573a08155fca8f0d300 nogeoclue.patch 59 default_libs
621f6db609b5c2d6cd0076cd63b9c60afd libnotify-0.7.patch 60 mkdir -p "$subpkgdir"/usr/share
61 mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
62}
63
64md5sums="c112cdca037f90168b04c0f12855006a gnome-bluetooth-3.10.0.tar.xz
639fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules" 659fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules"
66sha256sums="7ee4ad464abfed59f04d1a471eb25cfb95fc34eeefbe4c47580dbb50df2ab712 gnome-bluetooth-3.10.0.tar.xz
67b8acb8ea2e7f3588575cffd8ea14ec50c8641f518f2ea899771a508b299ea474 61-gnome-bluetooth-rfkill.rules"
68sha512sums="49602dedaad43652e542c8ca3682158a80a1e4b1cc7c568946af71357dc209600be654977fb444e8561f87bc7d9df8179bd0a808ab1aebd0fb904fec83865c65 gnome-bluetooth-3.10.0.tar.xz
6980b7fd0bc3e0f82c8d2d609ffed634200e63f61d9a134445df8e8511756b7fb423d338a1d12e42b91c57243097beaa3d4662856ec0507fb19a29b6de7ee9e4de 61-gnome-bluetooth-rfkill.rules"