aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-08 14:10:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 14:10:06 +0000
commitad309933eaa83e774c3d810fc6edefc2d3201484 (patch)
tree52dddebce789c099c9c4cdad3ba84ae01763154d
parent6a2548ebf9f70fdf4c367477f3308b3f26a99e38 (diff)
downloadalpine_aports-ad309933eaa83e774c3d810fc6edefc2d3201484.tar.bz2
alpine_aports-ad309933eaa83e774c3d810fc6edefc2d3201484.tar.xz
alpine_aports-ad309933eaa83e774c3d810fc6edefc2d3201484.zip
community/go: don't die in global scope
we have tools that parse APKBUILDs in aports so we should never die from global scope.
-rw-r--r--community/go/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 34b70f40a9..200489794a 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -62,7 +62,7 @@ mips) export GOARCH="mips" GOMIPS=softfloat ;;
62mips64) export GOARCH="mips64" GOMIPS64=softfloat ;; 62mips64) export GOARCH="mips64" GOMIPS64=softfloat ;;
63mips64el) export GOARCH="mips64le" GOMIPS64=softfloat ;; 63mips64el) export GOARCH="mips64le" GOMIPS64=softfloat ;;
64mipsel) export GOARCH="mipsle" GOMIPS=softfloat ;; 64mipsel) export GOARCH="mipsle" GOMIPS=softfloat ;;
65*) die "Unsupported arch" ;; 65*) export GOARCH="unsupported";;
66esac 66esac
67 67
68builddir="$srcdir"/go 68builddir="$srcdir"/go